Bug Hunting Session
Bug 113157 - LibreOffice crashes each time I restart Orca
Summary: LibreOffice crashes each time I restart Orca
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility
Depends on:
Blocks: a11y-Linux
  Show dependency treegraph
 
Reported: 2017-10-16 16:33 UTC by Alex ARNAUD
Modified: 2017-12-02 14:57 UTC (History)
4 users (show)

See Also:
Crash report or crash signature: ["libsdlo.so"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex ARNAUD 2017-10-16 16:33:23 UTC
Description:
Dear all,

I noticed lot of crashes after opening LibreOffice Impress. Today I've been victim of decade of crash during only the hour I spent on LibreOffice Impress due to the restart of the Orca screen reader.

I reproduce this issue on LibreOfficeDev 6.0 built the 2017-10-13 on Debian GNU/Linux 8.9 "Jessie"

Steps to Reproduce:
1. Open LibreOffice Impress
2. Add an image to the first slide
3. Select the image
4. Restart Orca

Actual Results:  
LibreOffice crases completely and recovery window doesn't work anymore.

Expected Results:
LibreOffice shouldn't crash


Reproducible: Always

User Profile Reset: No

Additional Info:
Best regards.


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Xisco Faulí 2017-10-16 18:46:27 UTC
Hello,
How do you restart orca, with 'nohup orca'? Could you please paste the info from Help - About LibreOffice?
I can't reproduce it in

Version: 6.0.0.0.alpha0+
Build ID: d4daf634cd9ce8d422d49669c324a2220eba54a9
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 2 Alex ARNAUD 2017-12-02 14:57:45 UTC
Dear all,

I've checked on Debian Sid with LibreOffice 5.4.3 and I cannot reproduce the issue.

Best regards.