Bug 113167 - Portrait documents in writer printing in landscape, getting cut off
Summary: Portrait documents in writer printing in landscape, getting cut off
Status: RESOLVED DUPLICATE of bug 110461
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-17 00:08 UTC by josh
Modified: 2017-10-17 08:09 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description josh 2017-10-17 00:08:48 UTC
Description:
If I create a document in Writer that is letter-sized (8.5" x 11") in portrait and open the Print dialog, the dialog's print preview shows the document outline in portrait, but the content is mapped onto the page in landscape orientation.  This also reflects how the page is actually printed, resulting in the content being cut off and some of the page not being used.

Interestingly, the Print Preview shows the document rendered properly, in Portrait.  It is only the Print Dialog that shows the document rendered incorrectly, and the actual printed output is also incorrect.

I first noticed this on 5.3.0.3, and it is still happening on 5.4.0.3.

Steps to Reproduce:
1. Create a letter-sized document in portrait orientation (8.5" x 11")
2. Add content to the document
3. Open the Print dialog
4. Observe that the preview shown in the dialog is rendering the document outline in portrait, but the content is in landscape and goes off the edge of the page.
5. Print the document, and observe that the content is printed as shown in the Print dialog's preview (i.e., incorrectly).

Actual Results:  
Document prints incorrectly, with the content going off the edge of the page.

Expected Results:
Documents printed in portrait should be printed with the content actually in portrait orientation, with content remaining on the page and not overlapping the page edge.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:55.0) Gecko/20100101 Firefox/55.0
Comment 1 Alex Thurgood 2017-10-17 08:09:02 UTC

*** This bug has been marked as a duplicate of bug 110461 ***