Bug 113173 - Sidebar: For some presentations Character and Paragraph range always collapse
Summary: Sidebar: For some presentations Character and Paragraph range always collapse
Status: RESOLVED DUPLICATE of bug 107804
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.4.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Impress-UX
  Show dependency treegraph
 
Reported: 2017-10-17 08:00 UTC by OfficeUser
Modified: 2017-11-03 09:50 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Presentation with bug (25.11 KB, application/vnd.oasis.opendocument.presentation)
2017-10-17 08:01 UTC, OfficeUser
Details
Screencast (1.25 MB, video/mp4)
2017-10-17 11:55 UTC, OfficeUser
Details
issue.ppt (169.00 KB, application/vnd.ms-powerpoint)
2017-10-17 12:23 UTC, OfficeUser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description OfficeUser 2017-10-17 08:00:25 UTC
- Please open the attached presentation
- Click into any of the text fields

Note: In the sidebar the two areas for Character and Paragraph are collapsed (the presentation includes a screenshot)

- Expand these two areas

- Click into an other text field

Result: Character and Paragraph are collapsed again.
Expected Result: Character and Paragraph should stay expanded.
Comment 1 OfficeUser 2017-10-17 08:01:00 UTC
Created attachment 137036 [details]
Presentation with bug
Comment 2 OfficeUser 2017-10-17 08:02:13 UTC
Strange: The bug happens only with some presentations.
Comment 3 Mohamed 2017-10-17 09:13:12 UTC
The issue is reproduced with the following environment :
    • Operating system : Windows 8.1 Pro 64-bits.
    • LibreOffice : Version: 5.4.2.2
		Build ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4
		CPU threads: 4; OS: Windows 6.2; UI render: default; 
		Locale: en-US (en_US); Calc: group

However it is working fine, “Character” and “Paragraph” still open even when selecting a text field in a different slide. This test is done with:
    • Operating system : Windows 8.1 Pro 64-bits.
    • LibreOffice : Version: 5.4.2.2
		Build ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4
		CPU threads: 4; OS: Windows 6.2; UI render: default; 
		Locale: en-US (en_US); Calc: group
Comment 4 OfficeUser 2017-10-17 09:23:24 UTC
@Mohamed:

Thanks. But what do you mean with "...issue is reproduced...However it is working fine...".

Can or can't you reproduce the bug? I can reproduce it on both Windows 5422 portable build and with 5422 Linux/Ubuntu.
Comment 5 OfficeUser 2017-10-17 09:29:43 UTC
I can still reproduce the bug with:

Version: 6.0.0.0.alpha0+
Build ID: c5a93cad149618bbd43632f1660a558c34bdbf7e
CPU threads: 8; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-10-07_01:12:25
Locale: de-DE (de_DE.UTF-8); Calc: group
Comment 6 OfficeUser 2017-10-17 09:36:05 UTC
I CANNOT reproduce it with:

Version: 5.0.0.5
Build ID: 437e4abdf9e72fd0a6e6f8697a0e659bc77f9b10
Locale: de-DE (de_DE.UTF-8)

==> Setting regression and bibisectRequest keyword.
Comment 7 Xisco Faulí 2017-10-17 11:13:05 UTC
I can't reproduce it in

Version: 6.0.0.0.alpha0+
Build ID: 616f21db9e50a77b0c02dfb123f871a742f46216
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Could you please create a screencast illustrating the issue?
Comment 8 Mohamed 2017-10-17 11:19:14 UTC
@OfficeUser, I am sorry if I confused you. I made a mistake. I meant to say that it worked fine and the issue is NOT reproduced on :
    • Operating system : Ubuntu 16.04.3 64-bits.
    • LibreOffice :Version: 5.4.2.2
		Build ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4
		CPU threads: 8; OS: Linux 4.4; UI render: default; VCL: gtk2; 
		Locale: ja-JP (ja_JP.UTF-8); Calc: group
Comment 9 OfficeUser 2017-10-17 11:55:50 UTC
Created attachment 137048 [details]
Screencast
Comment 10 OfficeUser 2017-10-17 11:56:05 UTC
Added screencast.
Comment 11 OfficeUser 2017-10-17 12:23:28 UTC
Created attachment 137050 [details]
issue.ppt
Comment 12 OfficeUser 2017-10-17 12:23:51 UTC
Added ppt file of the presentation.
Comment 13 Yousuf Philips (jay) (retired) 2017-10-17 14:31:47 UTC

*** This bug has been marked as a duplicate of bug 99537 ***
Comment 14 Timur 2017-10-17 15:09:04 UTC
This ine is direct duplicate of Bug 107804. And I'll See also previous one.

*** This bug has been marked as a duplicate of bug 107804 ***
Comment 15 OfficeUser 2017-11-03 09:50:13 UTC
Works for me with:

Version: 6.0.0.0.alpha0+
Build ID: cfbb8b5090537e79ba70e250ddee86d53facbe15
CPU threads: 8; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-10-18_22:54:20
Locale: de-DE (de_DE.UTF-8); Calc: group