Bug 113295 - 'Clear List' entry in Recent Documents appears in English rather than Slovenian
Summary: 'Clear List' entry in Recent Documents appears in English rather than Slovenian
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Gabor Kelemen
URL:
Whiteboard: target:6.0.0
Keywords:
Depends on:
Blocks: Main-Menu
  Show dependency treegraph
 
Reported: 2017-10-20 14:13 UTC by Martin Srebotnjak
Modified: 2017-10-22 07:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Clear List command remains in English (112.87 KB, image/png)
2017-10-20 14:13 UTC, Martin Srebotnjak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Srebotnjak 2017-10-20 14:13:56 UTC
Created attachment 137149 [details]
Clear List command remains in English

On 6.0alpha on macOS with Slovenian lang-pack (Slovenian is almost 100% localized as of this moment, not using the Pootle system) I can see an English string in the UI, that doesn't seem to appear in po files, which probably means it is not localizable.
It is in the drop-down list "Recent documents" in the grouped Librebar. Screenshot attached (with the command "Clear List" selected in English).
Comment 1 Martin Srebotnjak 2017-10-20 14:14:32 UTC
This happens in Writer, and the command is "Clear List".
Comment 2 Martin Srebotnjak 2017-10-20 14:18:37 UTC
The Notebook bar, not Librebar, sorry.
Comment 3 Martin Srebotnjak 2017-10-20 14:43:38 UTC
This is the command:
#. oPFZY
#: strings.hrc:43
msgctxt "STR_RESTORE_TOOLBARS"
msgid "~Reset"
msgstr "Pon~astavi"

Unless the shortcut key has changed from R to another letter (or string has in any other way changed) from October 18 (when I updated translation to pot templates of master) to October 20 (the day of the alpha build), this string is not displayed properly in its l10n form.

It appears OK localized in 5.4.x.
Comment 4 Martin Srebotnjak 2017-10-20 14:51:44 UTC
Same goes for this localized string, appearing in English: b2kUa
Comment 5 Yousuf Philips (jay) (retired) 2017-10-20 18:05:21 UTC
So 'Clear List' can be found in File > Recent Documents
Comment 6 Gabor Kelemen 2017-10-20 19:43:56 UTC
Confirmed with a current translations repository.
The string is translated in sl/framework/messages.po:

#: strings.hrc:36
msgctxt "STR_CLEAR_RECENT_FILES"
msgid "Clear List"
msgstr "Počisti seznam"

yet it does not appear on the UI.
Neither do other strings from the same file, like the "Untitled" default file name.

This affects other languages as well and happens because translations are converted to fwk.mo files and due to a typo in framework/source/fwe/classes/fwkresid.cxx LO looks for them in fwe.mo files.
Comment 7 Martin Srebotnjak 2017-10-20 20:40:02 UTC
Hah, well, I will always quote this bug report to those asking why Slovenian team uses its own translation system, not Pootle - because we can point to errors before they hit the l10n teams!
Comment 8 Commit Notification 2017-10-21 17:11:04 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e198087f32e98fdf569920a6f5fb51558919e2cb

tdf#113295 Fix typo in translation domain name

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.