Download it now!
Bug 113322 - Unable to insert media file that has a '[', ']', '#', ';', or '%' in its filename (Windows)
Summary: Unable to insert media file that has a '[', ']', '#', ';', or '%' in its file...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 109264 (view as bug list)
Depends on:
Blocks: Media-Insert
  Show dependency treegraph
 
Reported: 2017-10-21 12:30 UTC by Yousuf Philips (jay) (retired)
Modified: 2020-03-22 14:23 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2017-10-21 12:30:49 UTC
steps:
1. open impress
2. change slide layout to 'Title, Content'
3. click 'Insert Audio or Video' button
4. select a file that has a '[' or ']' in its filename
5. 'The format of the selected file is not supported' dialog will appear
6. click 'Insert Audio or Video' button again
7. remove the '[' and/or ']' from the filename
8. click 'Insert Audio or Video' button
9. it inserts successfully

Version: 6.0.0.0.alpha0+
Build ID: a1f93eee75450c3ab6bc623bfad4f850260b86d0
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: en-US (en_US); Calc: group
Comment 1 Yousuf Philips (jay) (retired) 2017-10-21 20:52:56 UTC
So i tested some more and '#' (mentioned here[1]), ';', and '%' also cause this error.

[1] https://forum.openoffice.org/en/forum/viewtopic.php?f=10&t=87055
Comment 2 Mohamed 2017-10-27 08:48:21 UTC
Issue reproduced for the following environment:
    • Operating system : Windows 8.1 Pro 64-bits.
    • LibreOffice : Version: 5.4.3.1 (x64)
      Build ID: 32c8895c6cae21571f364dbb059f419a743ee44d
      CPU threads: 4; OS: Windows 6.29; UI render: default; 
      Locale: en-US (en_US); Calc: group

However it is not reproduced on:
    • Operating system : Ubuntu 16.04.3 64-bits.
    • LibreOffice :Version: 5.4.3.1
     Build ID: 32c8895c6cae21571f364dbb059f419a743ee44d
     CPU threads: 8; OS: Linux 4.4; UI render: default; VCL: gtk2; 
     Locale: ja-JP (ja_JP.UTF-8); Calc: group
Comment 3 QA Administrators 2019-01-31 03:48:24 UTC Comment hidden (obsolete)
Comment 4 himajin100000 2019-02-10 23:04:25 UTC
https://docs.libreoffice.org/tools/html/classINetURLObject.html#aacc720283dca17d29119a450b3eee95d

possible cause:
INetURLObject constructor here 

https://opengrok.libreoffice.org/xref/core/avmedia/source/viewer/mediawindow.cxx?r=a33c2a1a#279
https://docs.libreoffice.org/tools/html/classINetURLObject.html#aacc720283dca17d29119a450b3eee95d

calls 

setAbsURIRef
https://docs.libreoffice.org/tools/html/urlobj_8cxx_source.html#l00690

which tries to parse the string as URL, and for URLs

'#' is used for fragment delimiter
'%' is used for percent encoding
':' is used for port

etc.
Comment 5 Aron Budea 2020-03-22 11:58:14 UTC
*** Bug 109264 has been marked as a duplicate of this bug. ***
Comment 6 Aron Budea 2020-03-22 14:23:43 UTC
Seems that this was fixed in 6.4 (buggy in 6.3.0.4, okay in 6.4.0.3).