Download it now!
Bug 109264 - Insert Audio or Video fails when file name contains a square bracket
Summary: Insert Audio or Video fails when file name contains a square bracket
Status: RESOLVED DUPLICATE of bug 113322
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Media
  Show dependency treegraph
 
Reported: 2017-07-21 19:25 UTC by WhoIsRich
Modified: 2020-03-22 11:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description WhoIsRich 2017-07-21 19:25:18 UTC
Steps to re-create:

- Launch Impress, start a new presentation, Insert, Audio or Video, and select a file.

- If file name contains a single square bracket [ ] in the name, it will say "The format of the selected file is not supported". The same file without square brackets will import successfully.

- It affects both audio and video files, and the position of the square bracket does not seem to matter. Other brackets such as curly braces and parenthesis work fine.

- This issue can obviously lead you think the file is encoded wrongly or you don't have the correct codecs.

- I have tested this on 3 different Windows 10 PCs, one of which was a fresh install with no codec packs, so only native WMV support, and same issue occurs when a square bracket was in the WMV file name.
Comment 1 tommy27 2017-07-23 07:08:41 UTC
I confirm issue under Win7x64 using LibO 5.3.4.2 and 6.0.0.0.alpha0+
Build ID: d7a2fd3e8262b8897ad06f01f25f46330e050e0c
CPU threads: 8; OS: Windows 6.1; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-07-20_08:26:15
Locale: it-IT (it_IT); Calc: group
Comment 2 WhoIsRich 2017-07-23 22:23:42 UTC
Downloaded LibreOffice 3.3.0 and 4.0.0.1 ( where option is 'Insert, Movie and Sound' ) and they have the same bug, so this is not a recent regression.

Tested on Ubuntu and it works fine, so seems to be Windows specific.
Comment 3 QA Administrators 2018-07-25 02:39:51 UTC Comment hidden (obsolete)
Comment 4 Aron Budea 2020-03-22 11:58:14 UTC
Looks like the same as bug 113322, let's close as duplicate.

*** This bug has been marked as a duplicate of bug 113322 ***