Bug 113330 - [Wayland] Navigator cannot be anchored inside the main window
Summary: [Wayland] Navigator cannot be anchored inside the main window
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.2.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Wayland
  Show dependency treegraph
 
Reported: 2017-10-21 20:17 UTC by Frank Brütting
Modified: 2017-11-08 20:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Brütting 2017-10-21 20:17:32 UTC
Description:
Using the RPM package, I could open the navigator and anchor it to the left side of the main window (like the regular sidebar resides on the right side). Sadly, this isn’t possible with the flatpaked version.

Steps to Reproduce:
Install the flatpaked version, press F5 and try it.

Actual Results:  
.

Expected Results:
.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Maxim Monastirsky 2017-10-22 15:59:37 UTC
I guess that's under Wayland? What happens if you try the same under X?
Comment 2 Frank Brütting 2017-10-22 22:36:16 UTC
There I could anchor it.

Now I have it in Wayland, too, but I cannot detach ich o_^.
Comment 3 Xisco Faulí 2017-10-23 09:07:13 UTC
You can't confirm your own bugs. Moving it back to UNCONFIRMED until someone else confirms it.
Comment 4 Maxim Monastirsky 2017-10-23 13:24:19 UTC
(In reply to zyklon87 from comment #2)
Thanks for confirming. It's a Wayland issue, not related to Flatpak. Unfortunately it isn't possible to implement docking under Wayland, as top level windows don't get access to the global coordinates. For that reason we intentionally disabled detaching such windows, as it will not be possible to reattach them again - https://cgit.freedesktop.org/libreoffice/core/commit/?id=a6d324f30bd5cfd09d54614d8df67b7857550429
Comment 5 Frank Brütting 2017-10-23 21:44:28 UTC
I set it to „new“, not “confirmed”! ;)

Would you mind implementing another method, that shows the navigator as a second side bar on the other side? Or could this be achived in Wayland in the future by some other means?
Comment 6 Maxim Monastirsky 2017-10-23 23:53:22 UTC
(In reply to zyklon87 from comment #5)
> Would you mind implementing another method, that shows the navigator as a
> second side bar on the other side?
No plans currently, but you can workaround it this way:

1) Open Writer and the navigator (at least once).
2) From the menu File > Close.
3) Menu Tools > Options..., switch to LibreOffice > Advanced, click on "Open Expert Configuration".
4) In the search box type "swriter/10366", Hit Enter.
5) Double click on the "Data" property.
6) Find the number "16" there, and replace with "4" (so now it looks something like "V2,V,128,AL:(4,4,0/0/270/240,270;240)")

Next time you open Writer, you'll have the navigator docked to the left. Of course you can also start LO once under X and dock it there.

> Or could this be achived in Wayland in the future by some other means?
That's a hard question. I think it _might_ be possible to achieve using a subsurface instead of a toplevel, but no evidence that such solution will fit with this use-case, and anyway will require some big changes to the code. So don't expect it to happen anytime soon.
Comment 7 Frank Brütting 2017-10-23 23:57:27 UTC
Thanks! But that’s a LITTLE but too much for my muscle memory, I’ll stick with X. ;)

If someone could include a shortcut button for this in the inspector, that would be really awesome! I therefore set this bug report to new again, if that’s ok!
Comment 8 Maxim Monastirsky 2017-10-24 00:22:53 UTC
(In reply to zyklon87 from comment #7)
> If someone could include a shortcut button for this in the inspector, that
> would be really awesome! I therefore set this bug report to new again, if
> that’s ok!
Sure, if the scope of the bug from now on is "include a shortcut button for this in the inspector", although I would prefer starting a clean new bug for such request.
Comment 9 Xisco Faulí 2017-10-24 06:51:42 UTC
(In reply to Maxim Monastirsky from comment #8)
> (In reply to zyklon87 from comment #7)
> > If someone could include a shortcut button for this in the inspector, that
> > would be really awesome! I therefore set this bug report to new again, if
> > that’s ok!
> Sure, if the scope of the bug from now on is "include a shortcut button for
> this in the inspector", although I would prefer starting a clean new bug for
> such request.

I agree. Better to create a new report from scratch.
@zyklon87, would you mind doing it, please?
regards
Comment 10 Frank Brütting 2017-10-24 22:00:21 UTC
Would’ve benn just a change in the title. Don’t you guys have plans, moving to GitHub or setting up a GitLab? This mailing list style bug tracker is pretty annoying… even Gnome accepted this now.

#113416
Comment 11 Buovjaga 2017-11-08 17:21:24 UTC
(In reply to zyklon87 from comment #10)
> Would’ve benn just a change in the title. Don’t you guys have plans, moving
> to GitHub or setting up a GitLab? This mailing list style bug tracker is
> pretty annoying… even Gnome accepted this now.

This is not related to Bugzilla. Even if we used GitHub or GitLab (which are not as powerful as Bugzilla regarding issue management), we would have advised to open a new report. The reason is that after a certain number of comments, changing the topic is highly confusing to all future readers of the report.
Comment 12 Frank Brütting 2017-11-08 19:53:03 UTC
What could be mentioned in the first post… ;)
Comment 13 Frank Brütting 2017-11-08 19:54:21 UTC
And you would get far more bug reports! Many people don’t want to register at tens of Bugzillas, and hassle around with this annoying interface.
Comment 14 Buovjaga 2017-11-08 20:02:42 UTC
(In reply to zyklon87 from comment #12)
> What could be mentioned in the first post… ;)

The next Bugzilla release will have a feature for comment editing. It would still be messy, though.

Mozilla is short on resources to port their own changes to the upstream Bugzilla, but it will happen eventually. Then we can change to the theme http://bugzilla.mozilla.org/ uses, if we wish. They are working on UX improvements all the time. It is sad that GNOME switched to an inferior platform due to the unfortunate situation with Mozilla's resource allocation.
Comment 15 Frank Brütting 2017-11-08 20:15:39 UTC
On a developer’s perspective maybe, but all the other people see this as a big step forward.