Download it now!
Bug 113420 - Sidebar: Wrap spacing presets arent based on measurement unit setting
Summary: Sidebar: Wrap spacing presets arent based on measurement unit setting
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3 all versions
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.2.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Writer-Images Sidebar-Properties-Wrap
  Show dependency treegraph
 
Reported: 2017-10-24 22:20 UTC by Frank Brütting
Modified: 2019-12-09 15:02 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Still persistent in v6.1.2.1 (216.03 KB, image/png)
2018-10-29 23:43 UTC, Frank Brütting
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Brütting 2017-10-24 22:20:10 UTC
Description:
All the layout settings are metric (page, borders, linespaces, etc), but the spacing of inserted images is imperial. Would you please change that to metric default distances? Would be consistent and more convenient, too.

Steps to Reproduce:
.

Actual Results:  
.

Expected Results:
.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Dieter 2017-10-28 08:38:22 UTC
I agree. If you compare

image dialog => Wrap => Spacing is metric

Properties in the sidebar => spacing is imperial


Version: 6.0.0.0.alpha1 (x64)
Build ID: c1d1f859b268f650143d48f294999cda0fa57350
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: de-DE (de_DE); Calc: group
Comment 2 QA Administrators 2018-10-29 03:58:36 UTC Comment hidden (obsolete)
Comment 3 Dieter 2018-10-29 09:57:39 UTC
Seems to be fixed.
Sidebar => Wrap => More Options => spacing is metric

=> RESOLVED WORKSFORME
Comment 4 Frank Brütting 2018-10-29 23:43:48 UTC
Created attachment 146154 [details]
Still persistent in v6.1.2.1
Comment 5 Frank Brütting 2018-10-29 23:44:09 UTC
No, it isn’t. At least not in v6.1.2.1.
Comment 6 Dieter 2018-10-30 08:15:07 UTC
Sorry, you're right. Still repro in LO 6.2.0.0.alpha1+
Comment 7 Xisco Faulí 2018-10-31 12:51:43 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=6f437466f96868cb10187c404ed84fb6d3dcc645

author	Susobhan Ghosh <susobhang70@gmail.com>	2016-08-13 19:23:54 +0530
committer	Katarina Behrens <Katarina.Behrens@cib.de>	2016-08-25 08:37:10 +0000
commit	6f437466f96868cb10187c404ed84fb6d3dcc645 (patch)
tree	dfa3a0863f0f7c23556d4ef079054133938cc3ba
parent	79f1315a02b1dd4dd7b4a78dea410c3192663522 (diff)
tdf#83830: Use SpacingListBox in Header/Footer and Sidebar Wrap Panel

Bisected with: bibisect-linux-64-5.3

Adding Cc: to Susobhan Ghosh
Comment 8 Xisco Faulí 2018-10-31 13:05:10 UTC
Hi Caolán,
I thought you could be interested in this issue as the measure unit are hardcoded in https://opengrok.libreoffice.org/xref/core/svx/inc/spacing.hrc#23
According to bug 105081 the same commit is causing problems with translations...
Comment 9 Caolán McNamara 2018-10-31 14:54:46 UTC
this is fixable
Comment 10 Commit Notification 2018-11-01 13:38:32 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/6d9a2557a0f0366fff169f3c3581414b3cec80bd%5E%21

Resolves: tdf#105081 and tdf#113420

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Xisco Faulí 2018-11-06 10:20:49 UTC
Verified in

Version: 6.2.0.0.alpha1+
Build ID: 5929d8ea469a971aa77371ed4b841c90a36e7da5
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded

@Caolán, thanks for fixing this!!