Bug 113479 - TRACK CHANGES: Annoying popup when Show Changes is off in Writer
Summary: TRACK CHANGES: Annoying popup when Show Changes is off in Writer
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:6.3.0 target:6.2.0.1
Keywords:
: 116526 (view as bug list)
Depends on:
Blocks: Track-Changes
  Show dependency treegraph
 
Reported: 2017-10-27 09:50 UTC by JIM7
Modified: 2018-12-19 09:56 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description JIM7 2017-10-27 09:50:13 UTC
Description:
"Would you like to Show Changes to avoid unnecessary delays?"
!!!!!!!!!!!!!!!!!!!!!!!
IF I WANTED TO SHOW CHANGES I WOULD HAVE CLICKED ON IT! 
PLEASE GET RID OF THIS ANNOYING POPUP, OR AT LEAST HAVE IT DEFAULT TO "NO"!!!!!

Steps to Reproduce:
1.Open LibreOffice file in "Writer". 
2.Check "Edit" to be sure "Show Changes" is off.
3.Begin editing.

Actual Results:  
Popup will appear with the first change or three.

Expected Results:
Popup appears, interrupting my editing, and pissing me off.


Reproducible: Always


User Profile Reset: No



Additional Info:
Let me choose my own options! Quit acting like microshit who thinks they know what's best for everyone.


User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Dieter Praas 2017-10-28 07:52:44 UTC
Not reproducible for me with

Version: 5.4.2.2 (x64)
Build-ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4
CPU-Threads: 4; Betriebssystem:Windows 6.19; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group

and

Version: 6.0.0.0.alpha1 (x64)
Build ID: c1d1f859b268f650143d48f294999cda0fa57350
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: de-DE (de_DE); Calc: group

To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test? I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present after a reset of your profile
Comment 2 JIM7 2017-10-28 08:11:47 UTC
Try it, editing a file of at least 10 pages length.
I guarantee it will pop up.
Comment 3 Dieter Praas 2017-10-28 08:22:37 UTC
I tried it with a document of 77 pages. Nothing happens.
Comment 4 JIM7 2017-10-29 06:56:27 UTC
Title of pop-up:   Do you want to show changes to avoid delays?

Below the title it says:

In the current document, changes are being recorded but not shown as such. In large documents, delays can occur when the document is edited. Showing changes will avoid delays.

>

To reproduce, "Save" a large document with the "Show Changes" turned off.
Wait 3 seconds, then pull it back up, and type in any new text. Pop-up will appear.
Comment 5 JIM7 2017-10-29 07:06:30 UTC
Oh, btw, the "Record Changes" function must be turned on for the entire operation.
Comment 6 Dieter Praas 2017-10-29 07:45:39 UTC
Still not reproducible for me with the steps you describe.

Have you ever tried it with a fresh user profile as I suggested in comment 1?
Comment 7 JIM7 2017-10-29 07:58:20 UTC
Did the reset. Had no affect.
Try another way:
>
Pull up a file for editing.
ensure that "Record Changes" is ON.
ensure that "Show Changes" is OFF.
type in a few words.
Click the red EXIT 'X' button, and when prompted, SAVE the changes.
>
Pull the document back up, and type in a minimum of 10 keystrokes.
hit the "Backspace" key a few times.
>
The pop-up appears for me, EVERY time
Comment 8 Gabor Kelemen 2017-10-31 11:51:03 UTC
This is it:

https://opengrok.libreoffice.org/xref/core/sw/uiconfig/swriter/ui/queryshowchangesdialog.ui

Maybe a "Dont ask again" box could be added. 
Or this entire feature dropped.
I find it annoying as well if that matters - so confirming.
Comment 9 JIM7 2017-10-31 11:54:10 UTC
My thanks to you all!
:)
Comment 10 Gabor Kelemen 2018-03-21 17:43:32 UTC
*** Bug 116526 has been marked as a duplicate of this bug. ***
Comment 11 Darrell 2018-03-21 19:58:21 UTC
Bug 116526, which was just marked as a duplicate of this bug, is mine. I don't find this popup as annoying as JIM7 appears to, but I can confirm that it continues to exist in Writer 6.0.2.1.

For anyone trying to duplicate this behavior, note that the popup is conditioned on rRedlineTable.size() > MAX_REDLINE_COUNT, which is currently defined to be 250 (see DocumentRedlineManager.cxx lines 2702-2722). I haven't dug into the code enough to figure out what determines rRedlineTable.size(), but it seems likely that it's a function of the number of distinct changes recorded. As I noted in my bug report, the timing of the popup feels random in a file with no recorded changes; it does not appear after the first change.

In my experience once the popup has appeared, opening a new file and setting Track Changes on and Show Changes off results in the popup appearing at the first change in the new file, even if the first file has been closed, so it appears that the table size is persistent within a session.
Comment 12 Michael Stahl (CIB) 2018-06-19 17:06:47 UTC
this dialog is displayed only if there are more than 250 tracked changes in the document; the easiest way to trigger it is with some "deletion" of text.
Comment 13 Commit Notification 2018-12-18 19:44:25 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/09657e3166e875f280095bf7d2f1f2ca8e022803%5E%21

sw_redlinehide_4b: tdf#113479 SetRedlineFlags() calls no longer...

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2018-12-18 19:44:32 UTC
Thorsten Behrens committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/866f10e75ddcd9dcfa327d02f587a1f322e6b6b5%5E%21

sw_redlinehide: fix tdf#113479 by removing nag dialog

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2018-12-18 21:32:39 UTC
Thorsten Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/7009749668311016c4e875e473bb8dc0da210022%5E%21

sw_redlinehide: fix tdf#113479 by removing nag dialog

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Michael Stahl (CIB) 2018-12-19 09:56:14 UTC
fixed now with the new layout based redline hiding; dialog was removed