Bug Hunting Session
Bug 113508 - Basic macro editor repeatedly replots when code selection changes.
Summary: Basic macro editor repeatedly replots when code selection changes.
Status: RESOLVED DUPLICATE of bug 107944
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-29 13:31 UTC by libreoffice.spam@fodder.homebuilt-lan.com
Modified: 2017-10-29 19:46 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description libreoffice.spam@fodder.homebuilt-lan.com 2017-10-29 13:31:42 UTC
Description:
The basic macro editor repeatedly replots the edit frame when code selection (highlighting) changes. Not only is it extremely annoying, it makes it very difficult to accurately to select code for actions such block copies, deletes, etc. It is bad enough that sometimes the wrong code is deleted.



Steps to Reproduce:
1. Tools/Macros/Edit Macros.
2. Select a module for editing.
3. Use the mouse to click/drag to select text.

Actual Results:  
Code frame is repeatedly cleared and re-plotted.

Expected Results:
Text should be highlighted without the entire code frame re-plotting.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Given me the expected results.


User-Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 Telesto 2017-10-29 17:10:42 UTC
Most likely fixed in LibreOffice 5.3.7 and 5.4.3. A pre-release is available here:
http://www.libreoffice.org/download/download/ (bottom of the page, above 'follow us')
Comment 2 raal 2017-10-29 19:46:23 UTC
Hello,

Thank you for submitting the bug. The bug has previously been reported, so this bug will be added as a duplicate of it. You will automatically be CCed to updates made to the other bug.

*** This bug has been marked as a duplicate of bug 107944 ***