Bug 113529 - Persian characters in PDF appear overlapped or in wrong position with B Nazanin font
Summary: Persian characters in PDF appear overlapped or in wrong position with B Nazan...
Status: RESOLVED DUPLICATE of bug 113428
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.4.2.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: PDF-Export RTL-Arabic
  Show dependency treegraph
 
Reported: 2017-10-30 17:47 UTC by Nima Dolatabadi
Modified: 2017-11-17 14:36 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
it is in Persian and some characters are wrong but in odt file all are OK. (48.88 KB, application/pdf)
2017-10-30 17:53 UTC, Nima Dolatabadi
Details
OTD and Screenshot of PDF file (159.08 KB, application/zip)
2017-11-02 17:08 UTC, Nima Dolatabadi
Details
pdfs of 5.3, 5.4, and master (156.50 KB, application/zip)
2017-11-06 10:02 UTC, Yousuf Philips (jay) (retired)
Details
5.3 vs 5.4 (216.53 KB, image/png)
2017-11-06 10:03 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nima Dolatabadi 2017-10-30 17:47:14 UTC
Description:
I'm using Persian language and when trying to export my `odt` file into `PDF` it goes successful but some characters goes wrong way.

Steps to Reproduce:
1.making an `odt` file using Persian language
2.exporting to PDF
3.opening PDF file

Actual Results:  
wrong characters for some text not all of them but it happens for every text I export to PDF

Expected Results:
It should have done it without any problem just like Microsoft Office 2010 above. 


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.75 Safari/537.36
Comment 1 Nima Dolatabadi 2017-10-30 17:53:12 UTC
Created attachment 137379 [details]
it is in Persian and some characters are wrong but in odt file all are OK.
Comment 2 Aron Budea 2017-11-01 22:15:25 UTC
Could you please also upload the ODT file, and a screenshot of the PDF where some of the incorrect characters are circled for reference?

Change back status to UNCONFIRMED after providing the files.
Comment 3 Nima Dolatabadi 2017-11-02 17:08:41 UTC
Created attachment 137478 [details]
OTD and Screenshot of PDF file
Comment 4 Nima Dolatabadi 2017-11-02 17:12:07 UTC
(In reply to Nima Dolatabadi from comment #3)
> Created attachment 137478 [details]
> OTD and Screenshot of PDF file

I just made the files you needed as a compressed file in .zip format.
regards
Comment 5 Aron Budea 2017-11-06 08:23:44 UTC
I downloaded B Nazanin font, and what I noticed is that it looks different (thicker) than the font in the PDF in the attachment. Could it be some kind of font subtsitution issue?
Comment 6 Yousuf Philips (jay) (retired) 2017-11-06 09:52:57 UTC
Confirmed in master and 5.4 daily and is a regression as doesnt happen in 5.3.7.

Version: 6.0.0.0.alpha1+
Build ID: 4058d85963e371be657f531d8f30e31381a9ccab
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group

Version: 5.4.4.0.0+
Build ID: 76c54edc8ee972c63da8ed1f5d6ab75ea552da46
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-5-4, Time: 2017-11-04_11:30:43
Locale: en-US (en_US.UTF-8); Calc: group
Comment 7 Yousuf Philips (jay) (retired) 2017-11-06 10:02:59 UTC
Created attachment 137563 [details]
pdfs of 5.3, 5.4, and master
Comment 8 Yousuf Philips (jay) (retired) 2017-11-06 10:03:25 UTC
Created attachment 137564 [details]
5.3 vs 5.4
Comment 9 Nima Dolatabadi 2017-11-06 10:44:03 UTC
(In reply to Yousuf Philips (jay) from comment #8)
> Created attachment 137564 [details]
> 5.3 vs 5.4

now what is the solution to this problem? do I need to downgrade my LibreOffice? if "yes", then How to do it?
best regards
Comment 10 Nima Dolatabadi 2017-11-06 10:47:19 UTC
(In reply to Aron Budea from comment #5)
> I downloaded B Nazanin font, and what I noticed is that it looks different
> (thicker) than the font in the PDF in the attachment. Could it be some kind
> of font subtsitution issue?

the answer is "no". because I have the right font to use. although I used all kinds of BNazanin font and they did not help. the other guy called Yusuf just found that the problem does not exist in lower versions.
regards
Comment 11 Yousuf Philips (jay) (retired) 2017-11-06 15:11:08 UTC
(In reply to Nima Dolatabadi from comment #9)
> now what is the solution to this problem? do I need to downgrade my
> LibreOffice? if "yes", then How to do it?
> best regards

Presently you can downgrade to 5.3 from the download page[1] of the website if you require an immediate fix until the situation is investigated more and resolved.

[1] http://www.libreoffice.org/download/
Comment 12 Xisco Faulí 2017-11-06 18:42:10 UTC
Regression introduced by 9eb4b14ffa57cd7bbdf0fc43096f5f1e65c8e388 which is the same as in bug 113428

*** This bug has been marked as a duplicate of bug 113428 ***
Comment 13 Nima Dolatabadi 2017-11-17 13:33:06 UTC
After upgrading to 5.4.3.2, the problem still exist and did not solved.
My problem still occures,
And why the topic was changed to "resolved" though the problem still exist?
Comment 14 Aron Budea 2017-11-17 14:36:56 UTC
It was marked as duplicate of another bug report, bug 113428. Please monitor that one for details.

Additionally, if an issue is set to RESOLVED FIXED or VERIFIED FIXED (as you can see in the other ticket), it means the bug is fixed in the development version. However, important bug fixes are backported into current release versions, and are released with the next update once backporting is done.

The Whiteboard field has "target:X.Y.Z" entries to show which version will contain the commit, in this case the fix will be part of the 5.4.4 update.

*** This bug has been marked as a duplicate of bug 113428 ***