Bug 113785 - On filtered list an autofill upwards erases data (steps in Comment 3)
Summary: On filtered list an autofill upwards erases data (steps in Comment 3)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.6.2 release
Hardware: All All
: medium normal
Assignee: Justin L
URL:
Whiteboard: target:7.4.0 target:7.3.1 target:7.2.6
Keywords: bibisected, bisected, regression
Depends on:
Blocks: AutoFill 119957
  Show dependency treegraph
 
Reported: 2017-11-12 14:38 UTC by August Koch
Modified: 2022-02-16 20:22 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (10.45 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-11-15 13:19 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description August Koch 2017-11-12 14:38:30 UTC
Description:
On filtered list an autofill upwards erases data in target-fields. Downwards is OK.
If the neighbourcells upside without filter are equal, the fillfunktion is ok.

This Bug exists on Libre for Windows and Linux. Tested altough on Vers.5.1.6.2 ..5.4.3.2


Steps to Reproduce:
1.switch on autofilter
2.take the autofiller and pull it upwards
3.

Actual Results:  

the upwards cells are erased instaed of decrease value

Expected Results:
libre works normal


Reproducible: Always


User Profile Reset: Yes



Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 Kevin Suo 2017-11-13 13:02:11 UTC
(In reply to August Koch from comment #0)
What do you mean by "autofilter" here? Do you mean auto-fill? Could you please provide a screenshot to show the bug?

If you mean autofill, I do not reproduce under Fedora 26 x64.
Comment 2 Buovjaga 2017-11-14 19:44:11 UTC
(In reply to Kevin Suo from comment #1)
> (In reply to August Koch from comment #0)
> What do you mean by "autofilter" here? Do you mean auto-fill? Could you
> please provide a screenshot to show the bug?
> 
> If you mean autofill, I do not reproduce under Fedora 26 x64.

Then August needs to attach an example file.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the document.
Comment 3 Buovjaga 2017-11-15 13:19:30 UTC
Created attachment 137778 [details]
Example file

For some reason the reporter emailed me personally with this file and information.

1- filter the "Data-2" to "test1"

2- Put with mousepointer for Example "C5" on the lower right edge and
pull it down to "C11" - The Result is OK - in Cell "C8" and "C11" is now
the Value "d".

3- Put with mousepointer on "C11" on the lower right edge and pull it up
to "C5" - the Result are BLANK Cells in "C8" and "C5"
Comment 4 Buovjaga 2017-11-15 13:38:07 UTC
I reproduce with the steps.

Not happening in 3.6.7

Arch Linux 64-bit
Version: 6.0.0.0.alpha1+
Build ID: 17cfe6e25d479428de308c22fcd218dcf8827840
CPU threads: 8; OS: Linux 4.13; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on November 15th 2017

Arch Linux 64-bit
Version 3.6.7.2 (Build ID: e183d5b)
Comment 5 raal 2017-12-11 18:56:35 UTC
This seems to have begun at the below commit.
Adding Cc: to Kohei Yoshida ; Could you possibly take a look at this one?
Thanks
 21e84025ea8a7c6a95fd2616711226def03cbd07 is the first bad commit
commit 21e84025ea8a7c6a95fd2616711226def03cbd07
Author: Matthew Francis <mjay.francis@gmail.com>
Date:   Thu May 28 18:47:06 2015 +0800

    source-hash-a995462e6855061816c6529c366f20ace2b45868
    
    commit a995462e6855061816c6529c366f20ace2b45868
    Author:     Kohei Yoshida <kohei.yoshida@collabora.com>
    AuthorDate: Fri Jan 31 18:05:05 2014 -0500
    Commit:     Kohei Yoshida <kohei.yoshida@collabora.com>
    CommitDate: Fri Jan 31 18:06:07 2014 -0500
    
        Take advantage of segment-based hidden flag storage.
    
        To avoid querying this states for every single column and row.
Comment 6 Buovjaga 2018-10-12 17:02:43 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2019-10-13 02:34:19 UTC Comment hidden (obsolete)
Comment 8 kabilo 2019-10-18 12:23:02 UTC
the bug is still present

Verze: 6.4.0.0.alpha0+ (x64)
ID sestavení: 758516295e5f69393bd78bb4af6e7214d48ece0b
Vlákna CPU: 4; OS: Windows 6.3 Build 9600; Vykreslování UI: výchozí; VCL: win; 
Národní prostředí: cs-CZ (cs_CZ); Jazyk UI: cs-CZ
Calc: CL
Comment 9 stragu 2021-06-04 08:33:38 UTC
I can still reproduce with:

Version: 7.2.0.0.alpha1+ / LibreOffice Community
Build ID: 774be6d793203183fe1856ffb8b720f00b48c2bb
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-06-03_19:22:06
Calc: threaded
Comment 10 Justin L 2022-02-09 12:30:37 UTC
Removing bug 119957 from duplicates because LO always (since at least 3.5) erased the contents of the hidden cells during the upward autofill.

This bug is particularly about NOT filling the visible cells, so we'll leave the other bug to cover the hidden cell aspect.
Comment 11 Commit Notification 2022-02-09 18:10:55 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/618084819babc839510860b74b36631749093c4c

tdf#113785 sc FillAutoSimple: also optimize in negative direction

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2022-02-10 09:05:11 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/bda200a5e9c4592bd61b7924fa171ec3265bfd24

tdf#113785 sc: IsDataFiltered must be normalized

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Xisco Faulí 2022-02-10 09:52:59 UTC
Verified in

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 1c0aa970650ffc7c749e0b5ea655ebb2d137c8ae
CPU threads: 8; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: es-ES (es_ES.UTF-8); UI: en-US
Calc: threaded

@Justin, thanks for fixing this issue!!
Comment 14 Commit Notification 2022-02-10 09:53:35 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/f3035cdb6a8d3ef56180640ef9d04031012250b9

tdf#113785 sc FillAutoSimple: also optimize in negative direction

It will be available in 7.3.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2022-02-10 15:02:53 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/35302c773ab352f2a9681839c6c11c67d765fbe8

tdf#113785 sc: IsDataFiltered must be normalized

It will be available in 7.3.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2022-02-16 11:04:18 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/99191703b528d8d7b0b9c5d84d76a6fdebbf5191

tdf#113785 sc FillAutoSimple: also optimize in negative direction

It will be available in 7.2.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2022-02-16 20:22:15 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/0b59601e415d186565278289e4d3613f727ef75c

tdf#113785 sc: IsDataFiltered must be normalized

It will be available in 7.2.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.