Bug 137774 - Filling hidden cells fails
Summary: Filling hidden cells fails
Status: RESOLVED DUPLICATE of bug 56799
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks: AutoFill
  Show dependency treegraph
 
Reported: 2020-10-26 16:16 UTC by Colin
Modified: 2022-02-11 05:43 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Colin 2020-10-26 16:16:17 UTC
Description:
According to the help facility   file:///C:/Program%20Files/LibreOffice/help/en-GB/text/scalc/guide/cellcopy.html?DbPAR=CALC#bm_id3150440

viz
Cells were hidden using the Hide command in the context menu of the row or column headers, or through an outline.
Copy, delete, move, or format a selection of currently visible cells.
All cells of the selection, including the hidden cells, are copied, deleted, moved, or formatted.

However, drag to copy and increment a matrix including the hidden cells/column fails to copy the hidden cells.

Also, if the missing value is inserted after the column has been exposed and then a number of rows are hidden and the original column re-hidden then the incrementation continues sequentially from the complete rows AFTER the hidden rows without incrementation for the hidden cells 

Steps to Reproduce:
insert the number 1 into C3
Select and drag to fill four cells upto and including F3
Create formula SUM(C3:F3) in cell G3
Note the result is 10
Select and Hide column D utilising the context menu
Select the range C3:G3
Drag to fill the matrix C4:G7
Note the results in Column G
Select Columns C>E and unhide from the column context menu

Note the missing values for the previously hidden cells D4>D7
Note Also the columnar increment allows for the hidden cells D4>D7

Now add the missing value "6" to D7
Hide rows 8>11 and column D
Select the C3:G3 matrix again and drag to increment C13:G15
Unhide all rows and columns
Note the missing row increments and also that the missing rows are not incrementally adjusted by +5 at row 12 but by +1
Significant contradiction in the incrementation methodology between missing rows and columns


Actual Results:
Test 1: The contents of Cells D4>D7 are blank and the subsequent columns are incremented as though the blank cells had correctly incremented

Test 2: The contents of rows 8>11 are blank and the incrementation continues from row 12 but unincremented for the hidden rows

Expected Results:
Test 1: D4>D7 should have incremented to 6

Test 2: Rows 8>11 should have incremented with rows 12>15 also incremented from row 11 results

Workaround - Select the column and set the width to an "invisible" value perhaps 0.01cm


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Version: 6.4.6.2 (x64)
Build ID: 0ce51a4fd21bff07a5c061082cc82c5ed232f115
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: default; VCL: win; 
Locale: sv-SE (en_GB); UI-Language: en-GB
Calc: threaded
Comment 1 Colin 2020-10-26 16:26:23 UTC
In the 2nd test I inadvertently advised to select the entire matrix starting at C3:G3 to create the new matrix to C15:G15. Of couse it's only necessary to select the last complete line of the original matric C7:G7.
Eating Umble Pie.
Comment 2 Buovjaga 2021-07-27 13:38:16 UTC
Reproduced

NixOS
Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 67e47070a7580a17804adce812cc2f98bfe7b51f
CPU threads: 16; OS: Linux 5.13; UI render: default; VCL: x11
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Comment 3 Buovjaga 2021-08-14 13:45:27 UTC
Bibisected with Linux 43all repo to range ee7084c4f720c932df67c8ff033dab4d8d556179..250feedd8e50e5eb52682a194823567ba5287c60

Out of which these seem relevant:

commit 73ff3a49a0891c7787f08eec86357c320a76c263
Author: Markus Mohrhard <markus.mohrhard@googlemail.com>
Date:   Wed Apr 11 22:02:06 2012 +0200

    first part for ScTable::GetAutoFillPreview
    
    Actually this is a bit more tricky. Currently it is showing wrong values
    for hidden rows/columns

commit 290a851bdc42a78426dea987ffbcb511e36c34fb
Author: Markus Mohrhard <markus.mohrhard@googlemail.com>
Date:   Wed Apr 11 21:53:30 2012 +0200

    ScTable::FillAuto should work with hidden rows/columsn now too

commit a6a0ea2f352f98b801bb6aade04caeb07e180403
Author: Markus Mohrhard <markus.mohrhard@googlemail.com>
Date:   Wed Apr 11 21:44:09 2012 +0200

    add unit test for autofill

commit f61cbce529d039bb0e208e81cf66974cc4428420
Author: Markus Mohrhard <markus.mohrhard@googlemail.com>
Date:   Wed Apr 11 21:35:59 2012 +0200

    make ScTable::FillSeries work correctly with hidden rows/columns

There was one intermediate state, where the cells were filled, but not incremented (I marked it as 'good').
Comment 4 Justin L 2022-02-11 05:03:30 UTC
I would consider autofill affecting hidden rows as a bug it if were to happen. It very intentionally does not work that way.  See bug 113785.
Comment 5 Justin L 2022-02-11 05:41:01 UTC
bug 56799 is discussing autofill - seems to be identical to this discussion.

Note the last comment 21 - NOTABUG.

*** This bug has been marked as a duplicate of bug 56799 ***
Comment 6 Colin 2022-02-11 05:43:16 UTC
(In reply to Justin L from comment #4)
> I would consider autofill affecting hidden rows as a bug it if were to
> happen. It very intentionally does not work that way.  See bug 113785.


Are you implying you'd sooner rewrite the help facility than fix the bug?
At the very least, a well-defined procedure would probably give the user the ability to select a preferred approach. Just like when the user is asked if they would prefer cell references to be expanded and adjusted when cells/rows are inserted or autofilters re-sort the cells according to value..............and many more examples which any user could identify. Reductio ad absurdum.
I imagine there is some mechanism with LO that detects "drag Filling" and presumably that mechanism could be improved to incorporate "would you like the hidden cells updated?"