Bug 113872 - Highlight colors change
Summary: Highlight colors change
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Highlight-Color
  Show dependency treegraph
 
Reported: 2017-11-16 08:41 UTC by ruiz.tur
Modified: 2019-07-07 13:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ruiz.tur 2017-11-16 08:41:27 UTC
Description:
Using .doc 97-2003 format, if you highlight some text with different colors, and then save and close the file, when you open it again, highlight colors are changed. For example, orange 1 or orange 2 will appear as yellow.

Steps to Reproduce:
1. Highlight some text with orange 1 or orange 2 (it also happens with more colors)
2. Save the file as .doc 97-2003
3. Close the file
4. Open the file again and see how the colors are changed to yellow

Actual Results:  
Some colors appear changed.

Expected Results:
All colors must be appear as the original.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 Dieter 2017-11-16 10:15:09 UTC Comment hidden (obsolete)
Comment 2 Buovjaga 2017-11-16 14:07:25 UTC
ruiz: do you know, if .doc format supports highlight other than yellow? Please link to some proof.
Comment 3 Telesto 2017-11-16 22:38:22 UTC
Same as bug 98944. Quote:
This thing happens because MS highlighting has only 15 highlighting color and when you save Writer text background \ highlighting to an MS format it is converted to this color palette.
It's the default behavior, but you can change this at Tools -> Option -> Load/Save -> Microsoft Office, to save Writer text background as MS Shading and so colors won't change. Nut in this case when you open that *.doc file in MS Word you could not change the text background with highlighting tool, but with the shading tool:
https://blogs.technet.microsoft.com/hub/2011/04/05/how-to-select-more-highlight-colors-in-word/

Before the 5.0 version sometimes we saved Writer text background as shading (doc, docx), sometimes as highlighting (rtf). From that version an option is added, so the user can select the preferred behavior. Highlighting became the default, because on LO UI text background is called highlighting. This option can be set also via user profile.
https://wiki.documentfoundation.org/ReleaseNotes/5.0#Word-compatible_text_highlighting