Bug 113879 - view two windows of the same file while using "web view"
Summary: view two windows of the same file while using "web view"
Status: RESOLVED DUPLICATE of bug 60129
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.3.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Web-Layout
  Show dependency treegraph
 
Reported: 2017-11-16 12:53 UTC by J22Gim
Modified: 2021-10-02 09:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description J22Gim 2017-11-16 12:53:57 UTC
Description:
I want to edit two parts of the same document (eg the beginning and the end of a 20-pages text). So in "normal view" I can go to Window->New Window and open a new window where I can see the 2nd view of my document. Great.

But I want to do exactly the same while using "web view" and not "normal view". "Web view" is MUCH more convenient for me for many reasons. But when I'm in "web view" I can not open a new window. And if I open a new window while in "normal view" and then I switch to "web view", the 2nd window is closed automatically :(

Version: 5.4.3.2
Build ID: 1:5.4.3~rc2-0ubuntu0.14.04.1~lo1
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group


Steps to Reproduce:
1. open Writer (works with any new, empty file or loaded file)
2. go to View->Normal
3. go to Window->New window
4. now you can edit the same document at two places simultaneously
5. try to do the same with "web" instead of "normal" view: it doesn't work
6. Follow 1-4 but now go (in any of the two windows) to View->Web and one of the windows closes automatically.

Actual Results:  
can't have two windows of the same document while using "web" view.

Expected Results:
I would love to have two windows of the same document (ie to be able to edit a document in two separate, simultaneous windows for example to change the text at the beginning and the references at the end) but while working under "web" view.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 Dieter 2017-11-16 21:32:06 UTC
Reproducible for me with

Version: 5.4.2.2 (x64)
Build-ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4
CPU-Threads: 4; Betriebssystem:Windows 6.19; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group
Comment 2 J22Gim 2018-01-22 12:02:09 UTC
Reproducible also with "User Profile Reset"
Comment 3 Buovjaga 2018-06-14 19:48:35 UTC
*** Bug 118172 has been marked as a duplicate of this bug. ***
Comment 4 J22Gim 2018-07-12 02:51:09 UTC
Any news about this? It is an actual bug, right?
Comment 5 sdc.blanco 2019-11-06 13:52:16 UTC
Reproduced with:  Version: 6.4.0.0.alpha1 (x64)
Build ID: cc57df8f942f239d29cb575ea5a7cb01405db787
CPU threads: 8; OS: Windows 10.0 Build 18362; UI render: GL; VCL: win; 

If View->Web is selected, then Window-->New Window is greyed out.

If this is intended (i.e. not a bug), then maybe it should be mentioned in the help file?  See here: 

https://help.libreoffice.org/6.4/en-US/text/shared/01/07010000.html?DbPAR=SHARED#bm_id6323129
Comment 6 J22Gim 2020-10-13 15:49:57 UTC
still the same in Version: 7.0.2.2
Build ID: 00(Build:2)
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Ubuntu package version: 1:7.0.2_rc2-0ubuntu0.20.04.2
Calc: threaded
Comment 7 J22Gim 2021-06-07 16:05:40 UTC
Still the same

Version: 7.1.3.2 / LibreOffice Community
Build ID: 10(Build:2)
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Ubuntu package version: 1:7.1.3~rc2-0ubuntu0.20.04.1~lo1
Calc: threaded
Comment 8 J22Gim 2021-09-21 21:17:17 UTC
Still the same behavior

Version: 7.2.1.2 / LibreOffice Community
Build ID: 20(Build:2)
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Ubuntu package version: 1:7.2.1~rc2-0ubuntu0.20.04.1~lo3
Calc: threaded
Comment 9 Mike Kaganski 2021-10-02 09:17:30 UTC

*** This bug has been marked as a duplicate of bug 60129 ***