Download it now!
Bug 113994 - qt5 VCL plugin crashes on startup
Summary: qt5 VCL plugin crashes on startup
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2017-11-22 20:54 UTC by Bernhard Rosenkraenzer
Modified: 2018-12-16 16:09 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
gdb trace log (75.25 KB, text/plain)
2017-11-23 16:23 UTC, Bernhard Rosenkraenzer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard Rosenkraenzer 2017-11-22 20:54:58 UTC
Trying to run LibreOffice 6.0.0.0.alpha1+ (git from today) with SAL_USE_VCLPLUGIN=qt5 results in an immediate crash:
*** Error in `/usr/lib64/libreoffice/program/soffice.bin': malloc(): memory corruption: 0x0000000001454280 ***
The splash screen and a window with title "soffice.bin" remain open (but there's nothing in the window).

The build works well with SAL_USE_VCLPLUGIN=default or SAL_USE_VCLPLUGIN=gtk

This is on OpenMandriva Cooker x86_64 -- linux 4.14, glibc 2.26, Qt 5.10.0-beta4, KF5 5.40.0, Plasma Desktop 5.11.3
Comment 1 Bernhard Rosenkraenzer 2017-11-22 23:45:49 UTC
slightly different behavior when rebuilt with --enable-debug: Window doesn't even open, error message isn't printed, but before aborting an extra warning is printed:

warn:opencl:54163:54163:desktop/source/app/opencl.cxx:137: Failed to initialize OpenCL for test

Seems unrelated though, Qt doesn't require OpenCL...
Comment 2 Julien Nabet 2017-11-23 14:10:05 UTC
Would it be possible you attach a backtrace by following this link? https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace
Comment 3 Bernhard Rosenkraenzer 2017-11-23 16:23:56 UTC
Created attachment 137945 [details]
gdb trace log
Comment 4 Bernhard Rosenkraenzer 2017-11-23 17:24:31 UTC
FWIW since it shows up in the backtrace, harfbuzz version is 1.7.1
Comment 5 Julien Nabet 2017-11-23 18:46:01 UTC
Thank you for your feedback.

I noticed several times "CRC mismatch", I wonder if the install of debug package is ok.
Comment 6 Pekka Helenius 2017-12-01 20:31:21 UTC
Happens here, too. Behavior is as described in the opening message.

[01/12/2017 19:30:14 - fincer: ~ ]$ export SAL_USE_VCLPLUGIN=qt5
[01/12/2017 19:30:18 - fincer: ~ ]$ libreoffice
*** Error in `/usr/lib/libreoffice/program/soffice.bin': malloc(): memory corruption: 0x000055b808392200 ***
Application Error

----------

Arch Linux x86_64
glibc 2.26
qt5-base 5.9.1
KF5 5.37.0
plasma-desktop 5.10.5

Reproducible with and without '--enable-64-bit' configure flag.
Comment 7 Bernhard Rosenkraenzer 2017-12-01 20:41:19 UTC
Still happens with Qt 5.10.0-rc1 and libreoffice 6.0.0-beta1
Comment 8 Pekka Helenius 2017-12-01 22:24:46 UTC
Yeah...that's sad. 

I have enabled '--enable-qt5' flag in my build configuration, and set 'qt5-base' + 'kcoreaddons' as dependencies for LibreOffice. I am using GIT version of the software. 

Is there still some extra/special configuration or specific dependency package versions needed for working Qt5 build?
Comment 9 QA Administrators 2018-12-03 03:58:25 UTC Comment hidden (obsolete)
Comment 10 Xavier Van Wijmeersch 2018-12-13 21:44:50 UTC
I haven build LO 6.2.0.0beta1 with Qt5 5.11.2 but not under plasma desktop but under kde4 desktop. (--enable-qt5 within my buildscript)
Starting from the console with "bash-4.4# SAL_USE_VCLPLUGIN=qt5 /root/slackbuild\ libreoffice/libreoffice\ 6.2/soffice --calc" i have no error messages nor a crash

Version: 6.2.0.0.beta1+
Build ID: 80fdc2491df857c910afbd30c025b4594cb1cf83
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 11 Michael Weghorn 2018-12-15 00:11:49 UTC
I can't reproduce here with a current master build and running Debian testing with Plasma.

Bernhard, Pekka: The following might help to narrow down the issue:

1) Are you running your Plasma session under X11 or Wayland?

2) Does the issue also occur when you directly run (adapt path as needed) e.g.
    SAL_USE_VCLPLUGIN=qt5 soffice.bin --writer
i.e. you call 'soffice.bin' directly rather than using the 'soffice' shell wrapper that sets several environment variables (in '${instdir}/program/ooenv') that might cause the crash (for a reason, though...)?
Comment 12 Bernhard Rosenkraenzer 2018-12-15 00:51:27 UTC
I'm running Plasma with X11, soffice.bin fails the same way as the wrapper.

Note I'm still on 6.1 though, haven't built the 6.2 beta or git master yet (currently updating, should have news on that soon).
Comment 13 Michael Weghorn 2018-12-15 08:31:58 UTC
OK, thanks for the info. If you're building yourself, it would be helpful if you can add the '--enable-debug' configure option, since that will make it possible to get a backtrace that shows more helpful information.
Comment 14 Bernhard Rosenkraenzer 2018-12-15 23:51:05 UTC
6.2 beta1 fixes the issue for me. I'm having some other unrelated issues (weird font sizes with SAL_USE_VCLPLUGIN=qt5 or SAL_USE_VCLPLUGIN=kde5), but they're obviously unrelated to this issue. Will open new reports for those.

Is this still reproducable with versions >= 6.2-beta1 for anyone else?
Comment 15 Michael Weghorn 2018-12-16 16:09:27 UTC
Thanks for retesting!
I'll set this bug to WORKSFORME then, since the issue no longer appears now. Should the problem come back or anybody else still has it, please reopen or open a new bug report.