Download it now!
Bug 114195 - Date field format switch between Libre Office and Excel
Summary: Date field format switch between Libre Office and Excel
Status: CLOSED DUPLICATE of bug 113889
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-01 14:07 UTC by Nope
Modified: 2017-12-01 14:42 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nope 2017-12-01 14:07:30 UTC
Description:
I create an XLS or XLSX file with Calc and I insert a date in a cell formatted as DATE - DD/MM/YY and I save it. 

Then if the same file is opened with Excel, the date format will be switched as MM/DD/YY and the language retrived by Excel is Chinese... 

This occurs systematically each time the file is first saved using Calc and then opened with Excel. 

The file is always shown correctly on Calc. 

If the file used is a planning table, a schedule or something like that, that bug becomes really dangerous!


Steps to Reproduce:
1. Create an XLS / XLSX file with Calc writing a date in a cell formatted as DD/MM/YY and save it
2. Open the same file with Excel --> the date will look like MM/DD/YY ! So try to adjust the format to DD/MM/YY and save it and close.
3. Open back again the same file with calc and just save it. 
4. Open back again the same file with Excel and the format will be switched again as MM/DD/YY

Actual Results:  
Date cell format is saved in a way that is not compatible with excel 

Expected Results:
Date cell format should be kept between different applications


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Eike Rathke 2017-12-01 14:42:22 UTC

*** This bug has been marked as a duplicate of bug 113889 ***