Bug 113889 - [FILESAVE]: changes format of date in cell from DD.MM.YY to MM.DD.YY with save file to .XLSX
Summary: [FILESAVE]: changes format of date in cell from DD.MM.YY to MM.DD.YY with sav...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Eike Rathke
URL:
Whiteboard: target:6.0.0 target:5.4.4
Keywords: bibisected, bisected, regression
: 114195 114551 114627 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-11-16 20:39 UTC by kompilainenn
Modified: 2017-12-21 17:51 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
example of XLSX with changed format of date in cell (4.94 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-11-16 20:42 UTC, kompilainenn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kompilainenn 2017-11-16 20:39:44 UTC
Description:
Locale is RU!
if you save file to format XLSX and open it in MSO Excel, then in Excel format of date in cell will be change from DD.MM.YY to MM.DD.YY. But if you open it XLSX in LibreOffice, then format of date will be OK - DD.MM.YY

Steps to Reproduce:
1. Create a new file in Calc
2. Enter into any cell 23.10.2017 (will be apply format DD.MM.YY)
3. Save file as .XLSX
4. Open file in MS Excel (we tried 2007, 2016)
5. See to format of our cell with date, it changed to MM.DD.YY

Actual Results:  
format of date changed from DD.MM.YY to MM.DD.YY if you open file in the MS Excel

Expected Results:
format of date didn't change if you open file in the MS Excel


Reproducible: Always


User Profile Reset: No



Additional Info:
it's regression 

i bibisected this bug using bibisect-win32-5.4

first bad commit:
source sha:51478cefaa4e265b42e3f67eda0a64767ff3efba

https://cgit.freedesktop.org/libreoffice/core/commit/?id=51478cefaa4e265b42e3f67eda0a64767ff3efba

author Eike Rathke <erack@redhat.com> 2017-04-18 14:57:00 (GMT)
committer Eike Rathke <erack@redhat.com> 2017-04-18 15:01:27 (GMT)
commit 51478cefaa4e265b42e3f67eda0a64767ff3efba


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 kompilainenn 2017-11-16 20:42:10 UTC
Created attachment 137817 [details]
example of XLSX with changed format of date in cell
Comment 2 Eike Rathke 2017-11-16 21:54:33 UTC
That was the fix for bug 107012 to have correct date order when converting between locales ... For Excel the format is needed in en-US locale context (where date order is MDY) but Excel does not handle the date particle order for the target locale. Only thing we can do is ignore change of date order when converting for Excel export.
Comment 3 Commit Notification 2017-11-16 23:18:13 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=eb8bd7f21103ed2349b44c954db977709de2e4ec

Resolves: tdf#113889 no date particle reordering when exporting to Excel

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Eike Rathke 2017-11-16 23:22:38 UTC
Pending review https://gerrit.libreoffice.org/44841 for 5-4
Comment 5 Commit Notification 2017-11-21 13:14:45 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=985523eee724f41eefb3aa84edcfcd1a4a3cf3db&h=libreoffice-5-4

Resolves: tdf#113889 no date particle reordering when exporting to Excel

It will be available in 5.4.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Eike Rathke 2017-12-01 14:42:22 UTC
*** Bug 114195 has been marked as a duplicate of this bug. ***
Comment 7 mechtilde 2017-12-01 14:45:43 UTC
.
Comment 8 Eike Rathke 2017-12-21 14:20:36 UTC
*** Bug 114627 has been marked as a duplicate of this bug. ***
Comment 9 Aron Budea 2017-12-21 17:51:22 UTC
*** Bug 114551 has been marked as a duplicate of this bug. ***