Download it now!
Bug 114250 - More document tabs in several main project windows in a Multi-Document-Interface (MDI)
Summary: More document tabs in several main project windows in a Multi-Document-Interf...
Status: RESOLVED DUPLICATE of bug 37134
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.3.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-05 04:06 UTC by csongor
Modified: 2017-12-05 19:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description csongor 2017-12-05 04:06:21 UTC
It would be nice to have a capability to keep several opened documents in one application window, similarly to how a modern browser can handle many tabs in several browser windows. 

For example, if I have 10 documents open in LO, plus 8 other applications then I may want to organise them somehow. Now I have two options in Windows:

- group all similar applications into one icon on the taskbar
- keep everything separately. 

The first one would merge all the opened LO files into one icon so I would have 9 icons all together (8 for the non-LO applications plus one for all the LO files). The second option would produce 18 icons on the task bar. 


I would like to organise my 10 opened LO documents in, say, three windows:
- Project #1: doc1.odt, doc2.odt, doc3.odt, spr1.ods, spr2.ods
- Project #2: doc4.odt, drw1.odg, drw2.odg
- Project #3: spr3.ods, spr4.ods. 

This would show 8+3=11 icons on the taskbar, 8 for the non-LO applications and 3 for the LO windows. 

One benefit is the better organised documents. Another, maybe even more important benefit would be that when I close the window of Project #1 then I could re-open all the files of that particular project with one click.
Comment 1 V Stuart Foote 2017-12-05 19:14:37 UTC
"Taskbar" is a MS Windows only structure--it is not cross platform so a non-starter.

Currently cross platform we support the main menu -> Windows list of links to all active documents of the current soffice.bin session. 

We've talked about doing a tabbed UI and that is open as bug 37134 and bug 33173

*** This bug has been marked as a duplicate of bug 37134 ***