Bug Hunting Session
Bug 114366 - UI: Button "default" in Style (Formatting) toolbar in Writer doesn't work in German UI
Summary: UI: Button "default" in Style (Formatting) toolbar in Writer doesn't work in ...
Status: RESOLVED DUPLICATE of bug 108461
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.3.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Toolbar-Formatting-Styles Style-Formatting-Writer-Toolbar
  Show dependency treegraph
 
Reported: 2017-12-09 15:23 UTC by lo
Modified: 2018-04-15 19:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lo 2017-12-09 15:23:44 UTC
Description:
The "default" button in the Style (Formatting) toolbar in Writer doesn't work with German translation. If I start lowriter with LANG=C everything works as expected. In German nothing happens if I click the "default" button. Btw., the German translation for that button is missing. (Though it's not the only button in that toolbar where the translation is missing.) I could spot this behavior on Arch Linux and macOS. I haven't tested other OS or languages.

Steps to Reproduce:
1. Start Writer with German translation.
2. Enable the toolbar "Formatting (Style)". (In German "Formatierungen (Formatvorlagen)")
3. Click on button "Strong".
4. Click on button "Default".

Actual Results:  
"Strong" is still enabled and "Default" is disabled.

Expected Results:
"Default" should be enabled and "Strong" disabled.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 5.4.3.2
Build-ID: 5.4.3-4


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 Dieter Praas 2017-12-09 16:20:32 UTC
I confirm it with

Version: 5.4.3.2 (x64)
Build-ID: 92a7159f7e4af62137622921e809f8546db437e5
CPU-Threads: 4; Betriebssystem:Windows 6.19; UI-Render: Standard; 
Gebietsschema: it-IT (de_DE); Calc: group
Comment 2 Yousuf Philips (jay) (retired) 2017-12-09 19:48:29 UTC
This issue is also there in the style menu.

*** This bug has been marked as a duplicate of bug 108461 ***