Bug 114489 - Checkbox source format in chart "format label" menu not checked after checking it previously in the "format label" menu
Summary: Checkbox source format in chart "format label" menu not checked after checkin...
Status: RESOLVED DUPLICATE of bug 95425
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needUITest
Depends on:
Blocks: Chart-Labels
  Show dependency treegraph
 
Reported: 2017-12-15 16:52 UTC by Ahmed GHANMI
Modified: 2020-05-26 16:09 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Calc File where the issue is reproduced (16.52 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-12-15 16:55 UTC, Ahmed GHANMI
Details
Video that expalin steps to reproduce the issue (1.83 MB, video/mp4)
2017-12-15 16:56 UTC, Ahmed GHANMI
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ahmed GHANMI 2017-12-15 16:52:37 UTC
Description:
When we choose to format data labels on chart graphic in calc file (mouse click right + choose "Format data labels ..." in chart graphic menu) a menu will appear "Data Labels for Data Series 'Column C'" then we choose "Data Labels" page then press on "Number Format" button a new "Format Number" menu will appear if we modify any value in this page then we press ok button then we press ok button in "Data Labels for Data Series 'Column C'" menu and we finnaly we repeat the steps described we'll find that the values are not modified.  

Steps to Reproduce:
1.Open the Calc File attached
2.Click right on the orange section of the chart
3.Select Format data labels ...
4.Data Labels for Data Series 'Column C'" menu will appear
5.Choose "Data Labels" page
6.Press on "Number Format" button
7."Format Number" menu will appear 
8.Check source format Checkbox 
9.Press ok button "Format Number" menu will be closed
10.Press ok button "Data Labels for Data Series 'Column C'" menu will be closed
11.Click right on the orange section of the chart
12.Select Format data labels ...
13.Data Labels for Data Series 'Column C'" menu will appear
14.Choose "Data Labels" page
15.Press on "Number Format" button
16."Format Number" menu will appear
17.Note the state of checkbox "source format"

PS : I've attached a video to show those steps above.
 

Actual Results:  
17. Checkbox "source format" is not checked

Expected Results:
17. Checkbox "source format" should be checked


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Ahmed GHANMI 2017-12-15 16:55:12 UTC
Created attachment 138463 [details]
Calc File where the issue is reproduced
Comment 2 Ahmed GHANMI 2017-12-15 16:56:25 UTC
Created attachment 138464 [details]
Video that expalin steps to reproduce the issue
Comment 3 Jacques Guilleron 2017-12-16 18:02:58 UTC
Hi Ahmed,

I reproduce with
LO 4.3.0.2 Build ID: 14ed55896fdfcb93ff437b85c4f3e1923d2b1409
and upper versions where the behaviour is the same the one you descibe.
but not with
LO 4.3.0.1 Build ID: 67f5430184326974072b65403ef1d9d934fc4481
and previous versions
under Wiindows 7

Thank you to have report it.
Comment 4 Xisco Faulí 2018-05-03 08:47:57 UTC
I'm not sure this is a regression.... I can reproduce it in

- Version: 4.2.0.0.alpha1+
Build ID: fc8f44e82de4ebdd50ac5fbb9207cd1a59a927e3

- Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

- LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 5 Xisco Faulí 2018-08-02 09:00:22 UTC
Dear Ahmed GHANMI,
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assigned it back to yourself if you're still working on this.
Comment 6 QA Administrators 2019-08-19 06:58:00 UTC Comment hidden (obsolete)
Comment 7 NISZ LibreOffice Team 2020-05-26 16:09:00 UTC
This seems to work now since:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=e4a087876da2584b772480d4fe8fc58081dfe0b8

author	Balazs Varga <balazs.varga991@gmail.com>	2020-03-25 11:31:02 +0100
committer	László Németh <nemeth@numbertext.org>	2020-04-09 10:25:52 +0200

tdf#95425 follow-up: enable "Source format" checkbox of data label

*** This bug has been marked as a duplicate of bug 95425 ***