Bug Hunting Session
Bug 114656 - Hebrew characters placed at excessive spaces when having certain Hebrew punctuation
Summary: Hebrew characters placed at excessive spaces when having certain Hebrew punct...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-Hebrew
  Show dependency treegraph
 
Reported: 2017-12-22 21:34 UTC by Maxim Iorsh
Modified: 2018-12-27 16:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Demo ODT document (9.23 KB, application/vnd.oasis.opendocument.text)
2017-12-22 21:35 UTC, Maxim Iorsh
Details
Bug screenshot (9.23 KB, application/vnd.oasis.opendocument.text)
2017-12-22 21:35 UTC, Maxim Iorsh
Details
Bug screenshot (80.79 KB, image/png)
2017-12-22 21:36 UTC, Maxim Iorsh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maxim Iorsh 2017-12-22 21:34:36 UTC
Description:
The amount of expanded spacing between characters is affected by non-base characters, such as diacritical marks

Steps to Reproduce:
1. Install David CLM font (available as fonts-hebrew package or at culmus.sf.net)
2. Open the attached ODT file
3. Observe different spacing between the two lines of text

Actual Results:  
Line 1 is more expanded than line 2, despite having the same letters

Expected Results:
Line 1 should have the same total length as line 2


Reproducible: Always


User Profile Reset: No



Additional Info:
Looks like non-base characters (diacritical marks under the letters) affect the spacing between characters, while in fact they should be ignored

Version: 5.1.6.2
Build ID: 1:5.1.6~rc2-0ubuntu1~xenial2
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; 
Locale: he-IL (en_US.UTF-8); Calc: group


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Maxim Iorsh 2017-12-22 21:35:17 UTC
Created attachment 138599 [details]
Demo ODT document
Comment 2 Maxim Iorsh 2017-12-22 21:35:40 UTC
Created attachment 138600 [details]
Bug screenshot
Comment 3 Maxim Iorsh 2017-12-22 21:36:20 UTC
Created attachment 138601 [details]
Bug screenshot
Comment 4 Buovjaga 2017-12-26 17:44:02 UTC
Can you test with 5.4.4 to see, if the problem remains? A quick way is to use an AppImage http://libreoffice.soluzioniopen.com/

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 5 Maxim Iorsh 2017-12-27 10:26:38 UTC
Reproduced with AppImage "full" 5.4.4.2
Comment 6 raal 2017-12-28 22:03:13 UTC
I can confirm with Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a) and 6.1; Linux
Comment 7 Eyal Rozenberg 2018-12-27 16:42:30 UTC
Still seeing this with 

Version: 6.2.0.0.beta1
Build ID: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
CPU threads: 4; OS: Linux 4.9; UI render: default; VCL: gtk3; 
Locale: en-US (en_IL); UI-Language: en-US