Bug 114695 - Calc Format->Page->Header dropdown extends outside the dialog when the file path is long
Summary: Calc Format->Page->Header dropdown extends outside the dialog when the file p...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All Linux (All)
: medium minor
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.2.0.2 target:6.1.5
Keywords: bibisected, bisected, regression
: 120509 (view as bug list)
Depends on:
Blocks: Page-Dialog
  Show dependency treegraph
 
Reported: 2017-12-26 06:43 UTC by Kevin Suo
Modified: 2019-01-08 10:38 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (bad) (68.56 KB, image/png)
2017-12-26 06:43 UTC, Kevin Suo
Details
screenshot (good expected) (36.00 KB, image/png)
2017-12-26 06:44 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2017-12-26 06:43:04 UTC
Created attachment 138650 [details]
screenshot (bad)

In Calc, if the file path is to long, when you open the Format -> Page dialog not all the elements are shown.

Steps to Reproduce:

1. Create a new ods file and save it in a folder such as:
"/home/suokunlong/this/is/a/veryyyyyyyyyyyyyyyyyyyyyyyyyy/looooooooooooooooooooooooooooooooong/pathhhhhhhhhhhhhhhh/to_test_the_page_format_dialog"

2. Go to Format -> Page -> Header (or Footer) to observe the dialog controls.
--> Elements such as character formatting etc are floated to the left invisible area. 

This makes me not able to set the character formatting of the page headers.

This may be caused by the long file path showing in the dropdown list on this dialog.
Comment 1 Kevin Suo 2017-12-26 06:44:58 UTC
Created attachment 138651 [details]
screenshot (good expected)

Version:5.4.4.2
Build ID:5.4.4.2-1.fc27
CPU Thread:4; OS:Linux 4.14; UI render:Default; VCL: gtk3; 
Locale:zh-CN (zh_CN.UTF-8); Calc: group
Comment 2 raal 2018-01-11 22:20:42 UTC
I can confirm with Version: 6.1.0.0.alpha0+
Build ID: 88f6ffeb9e0c0b942c2b0bc9d60af7bb7a6caaf8
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk3; 

regression, works in LO 4.1.
Comment 3 Xisco Faulí 2018-01-16 10:41:25 UTC
I can't reproduce it in

Version: 6.1.0.0.alpha0+
Build ID: 8f28db9515e049fa7e0aa26fe32513e3486dcfaf
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

The dialog grows to the sizes, showing all elements...
Comment 4 Kevin Suo 2018-01-16 10:59:40 UTC
(In reply to Xisco Faulí from comment #3)
What is your OS and display specs? What happen if you put is in a even longer path?

Mine is Fedora Gnome.
Comment 5 Aron Budea 2018-05-31 13:50:04 UTC
Still there with the latest commit of 6.1 bibisect build.
Also reproduced with LO 5.2.0.4, can't test in earlier versions, as it doesn't occur with 'gen' VCL plugin, and older LO versions don't start with 'gtk' VCL plugin for me.

(In reply to Xisco Faulí from comment #3)
> I can't reproduce it in

If it still fits, try with a longer directory name, once it's too long, the dropdown, but only the dropdown will extend too much to the left to accomodate even the longest name in the list.
Comment 6 Muhammet Kara 2018-05-31 13:59:27 UTC
Reproduced on master with:

Sürüm: 6.2.0.0.alpha0+
İnşa №: 99e38e8f152157bb4ac2e7908deb0ce0be25a509
İşlemci süreçleri: 8; İşletim Sistemi:Linux 4.16; UI gerçekleyici: varsayılan; VCL: gtk3; 
Yerel: tr-TR (en_US.UTF-8); Calc: group threaded
Comment 7 Buovjaga 2018-07-12 16:07:06 UTC
Bibisected with Linux 41max, had to skip some commits due to the dialog being weird, but out of the remaining haystack, this stands out:

commit 406e1cc9721fbc2e6bf0c458547b7f2c29a1193f
Author: Matthew Francis <mjay.francis@gmail.com>
Date:   Fri Sep 18 11:11:07 2015 +0800

    source-hash-70af05cf740d3b4639f110489dc0e9e1e7571931
    
    commit 70af05cf740d3b4639f110489dc0e9e1e7571931
    Author:     Olivier Hallot <olivier.hallot@edx.srv.br>
    AuthorDate: Wed May 1 20:47:34 2013 -0300
    Commit:     Caolán McNamara <caolanm@redhat.com>
    CommitDate: Mon May 13 15:45:34 2013 +0100
    
        Convert Calc page header/footer content to Widget UI
Comment 8 Buovjaga 2018-11-25 18:06:14 UTC
*** Bug 120509 has been marked as a duplicate of this bug. ***
Comment 9 Commit Notification 2018-12-20 21:14:21 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/ebcb1fa80654849792bc3c296f61090138f99e20%5E%21

Resolves: tdf#114695 limit width of this combo

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2018-12-20 21:14:31 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/2923760cb8da0d6106e12bcb3d0ab1cc970d41ce%5E%21

Resolves: tdf#114695 limit width of this combo

It will be available in 6.2.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Caolán McNamara 2018-12-20 21:25:21 UTC
backport to 6-2 and 6-1 in gerrit
Comment 12 Commit Notification 2019-01-08 10:38:10 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/a1f3bcc6312a599996fee9825703394fe5b3a20a%5E%21

Resolves: tdf#114695 limit width of this combo

It will be available in 6.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.