Bug Hunting Session
Bug 114699 - File Open Icons corrupted on high DPI displays
Summary: File Open Icons corrupted on high DPI displays
Status: RESOLVED DUPLICATE of bug 119020
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.3.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Icon-Themes
  Show dependency treegraph
 
Reported: 2017-12-26 14:05 UTC by bugzilla2
Modified: 2018-10-05 15:03 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Shows the distorted Icons in the LibO Start Window (6.93 KB, image/png)
2017-12-26 14:06 UTC, bugzilla2
Details
Shows the broken FileOpen-Icon in Writer (6.31 KB, image/png)
2017-12-26 14:07 UTC, bugzilla2
Details
broken FilOpen Icons taken from 6.0 cache directory (2.76 KB, application/zip)
2018-02-04 11:51 UTC, bugzilla2
Details
Comparison between Icons rendered in 6.0/5.4 (111.83 KB, image/png)
2018-02-04 12:22 UTC, bugzilla2
Details
Sample of 5.4.4 windows (369.33 KB, image/jpeg)
2018-02-05 22:10 UTC, Daniel C Scearce
Details
Launcher icons 6.1 (66.70 KB, image/png)
2018-08-09 01:05 UTC, Robert Berg
Details
Writer icons 6.1 (70.25 KB, image/png)
2018-08-09 01:06 UTC, Robert Berg
Details
Menu icons 6.1 (97.52 KB, image/png)
2018-08-09 01:06 UTC, Robert Berg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugzilla2 2017-12-26 14:05:03 UTC
Description:
1.) Icons for "Open File" (Datei öffnen) and "Remote Files" (Dateien auf Server) in Start-Window show wrong colors (Screenshot attached). Tested on MacBook Pro with Retina Display on Windows 10 with current Display Driver. Happens in Classic Rendering and OpenGL.
(Regresssion compared to 5.4.4)

2.) The "Open" Icon in Writer is broken (See attached Screenshot). Seems to happen only on HiDPI Displays (fails on MacBook Pro with Retina Display, OK on Thinkpad T61 with normal DPI). Happens in Classic Rendering and OpenGL.
(Regresssion compared to 5.4.4)

Steps to Reproduce:
1. Open the LibreOffice Start-Window on a Computer with HiDPI Display.
2. Look at the FileOpen Icons.

Actual Results:  
Icons are broken/black.

Expected Results:
Icons should look the same as on Normal-DPI Displays.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.97 Safari/537.36 Vivaldi/1.94.1008.40
Comment 1 bugzilla2 2017-12-26 14:06:16 UTC
Created attachment 138655 [details]
Shows the distorted Icons in the LibO Start Window
Comment 2 bugzilla2 2017-12-26 14:07:21 UTC
Created attachment 138656 [details]
Shows the broken FileOpen-Icon in Writer
Comment 3 Daniel C Scearce 2017-12-29 19:30:56 UTC
I second this bug report. No matter how many fresh installs, it keeps happening.
Comment 4 Heiko Tietze 2018-01-03 10:44:03 UTC
Removing the UX keyword. If this is a bug (QA should confirm with setting to NEW) it has to get fixed of course. UX contribution is not needed.
Comment 5 bugzilla2 2018-02-04 11:49:43 UTC
Issue still exists in 6.0 Release :(

At least I could nail down the issue a bit. The problem seems to be a change in the LibO Code which takes the GUI-Icons out of the Theme-Zip-File (for example: images_tango.zip) extracts, scales and copies them to the cache-directory. In LibO until 5.4.4 this works (quiet) well. In LibO 6 there is a change that does two things:

1.) Icons that are 256 colors (as the mentioned FilOpen-Icons in Startpage) get corrupted. I'l add a zip containing two of those broken icons taken from the cache-directory).

2.) The changed routine also introduces badly image-scaling. Icons in 6.0 look uglier (a little bigger and a lot more jagged) than in 5.4.4. If I take the cached Icons from 5.4.4 and copy them over to the 6.0 cache, the gui looks the same as in 5.4.4, so its really just the way LibO 6 converts the icons from the zip to the cache. I'll also ad a comparison graphic that point out the difference in icon-conversion from 5.4.4 to 6.0.

For testing, you need to clear the cache directory, start LibO, close all LibO-Instances, and open LibO again. Only than you will see the Icons "built" by the current LibO-Version.
Comment 6 bugzilla2 2018-02-04 11:51:42 UTC
Created attachment 139568 [details]
broken FilOpen Icons taken from 6.0 cache directory
Comment 7 bugzilla2 2018-02-04 12:22:17 UTC
Created attachment 139569 [details]
Comparison between Icons rendered in 6.0/5.4
Comment 8 bugzilla2 2018-02-05 14:21:15 UTC
Why is the earliest affected Version always changed back to 5.4.3.2, when I have reported, that only Version 6.x is affected?
Comment 9 Daniel C Scearce 2018-02-05 15:08:40 UTC
@ bugzilla2@cb-computerservice.at , because that is the earliest version affected, it's as simple as that. I invite you to test it out. Either way, that's what I have installed, and it is present on that version. Thanks,
Comment 10 Daniel C Scearce 2018-02-05 15:14:31 UTC
I downloaded from the public download link, by the way. I viewed your image; I don't know why you didn't experience the problem then. For me, LibreOffice must be loaded twice to experience the problem. If I remember correctly on version 5.4, deleting the cache solves the problem for one load up of the program, but it quickly gets corrupted after that. I do agree that the unzipping algorithm is the cause. Wish I could go in and fix it, but this is not a programming language that I am skilled in.
Comment 11 bugzilla2 2018-02-05 15:20:03 UTC
@Daniel:
Whats the number in your cache-directory? Mine is 200, I guess that means it is scaled to 200%. I can't reproduce that in 5.4, but maybe you have a different scale factor...

Btw: If you just want to get rid of the issue for yourself, convert the corresponding Icons in the Tango-images.zip to 8bit/channel (instead of 256 Colors) and delete the cache. The the Icons should work.
Comment 12 Daniel C Scearce 2018-02-05 15:57:45 UTC
Awesome thanks. For the record, I’m using windows x64 and in the tango folder it is also 200 for me. I’ll post the installer name and SHA256 later.
Comment 13 bugzilla2 2018-02-05 16:02:27 UTC
Is your LibO also 64Bit or 32Bit? Because even though im on 64Bit Windows, I still use/test only 32Bit Versions of LibO.
Comment 14 bugzilla2 2018-02-05 16:28:37 UTC
Just made a clean (parallel) install of LibO 5.4.3.2 (32Bit LibO on 64Bit Windows 10 with 200% scaling) and I can't reproduce your error. No broken Icons for me in 5.4 series. Please report back your LibO "bittnes" and what else could be different on your machine.
Comment 15 bugzilla2 2018-02-05 16:46:38 UTC
Tried again with LibO 5.4.3.2 in 64Bit flavor -> still not reproduce-able on 2 different systems. I really would like to know why this happens on your setup?! Anyway, for me earliest affected version remains 6.0 Alpha 1.
Comment 16 Daniel C Scearce 2018-02-05 22:08:07 UTC
The command "openssl dgst -sha256 LibreOffice_5.4.4_Win_x64.msi" produces the following:

SHA256(LibreOffice_5.4.4_Win_x64.msi)= 0738dd24b5ba9a9dab079df34db7543d9d8b9a7a2989c0a4934debbaea8a5c8f

That is the installer that I used; yes, when I initially became active on this bug, I was using an earlier version that also had the problem, but at least now you know exactly what I have installed.

LibreOffice was one of the first things I installed ( I literally reinstalled Windows once in an attempt to fix this).

By the way, as long as this gets fixed in 6+, I personally could care less about 5.4.
Comment 17 Daniel C Scearce 2018-02-05 22:10:57 UTC
Created attachment 139615 [details]
Sample of 5.4.4 windows
Comment 18 bugzilla2 2018-02-06 12:47:03 UTC
(In reply to daniel from comment #16)
> By the way, as long as this gets fixed in 6+, I personally could care less
> about 5.4.

It's important to determine the right version that the bug was introduced and the circumstances that need to apply to trigger the bug. May I contact you via mail so we can figure out the differences between our systems without flooding this report?
Comment 19 Daniel C Scearce 2018-02-06 14:19:09 UTC
I deleted the entire LibreOffice folder in appdata, loaded once (fine), loaded second time (corrupted).
Still using 5.4.4., no other changes.
Feel free to contact me at dcscearce@aumail.averett.edu .
Comment 20 Buovjaga 2018-03-07 16:52:57 UTC
*** Bug 115914 has been marked as a duplicate of this bug. ***
Comment 21 Daniel C Scearce 2018-06-07 18:35:43 UTC
Changed title in hope that keyword searches might find this bug better.
Comment 22 Buovjaga 2018-06-20 18:45:56 UTC
*** Bug 117674 has been marked as a duplicate of this bug. ***
Comment 23 Robert Berg 2018-07-17 21:52:22 UTC
I submitted this as bug 117674, adding more info here to help get it fixed.

I had to get a new PC under warranty exchange. I installed a fresh LibreOffice (as well as the rest of my programs), and the first launch displayed the icons just fine, any launch after that first launch shows the corrupted icons. This is using version 6.0.5, using a freshly downloaded installer from LibreOffice.org, hopefully this can help find a resolution.
Comment 24 Robert Berg 2018-08-09 01:03:20 UTC
Just installed LO 6.1, and cleared the cache before running it. First launch was great, additional launches **ALL** icons in the window(s) are messed up (sidebars, toolbars, menus, EVERYWHERE). It is no longer just the open and remote open icons, it is every single icon.
Comment 25 Robert Berg 2018-08-09 01:05:56 UTC
Created attachment 144044 [details]
Launcher icons 6.1
Comment 26 Robert Berg 2018-08-09 01:06:18 UTC
Created attachment 144045 [details]
Writer icons 6.1
Comment 27 Robert Berg 2018-08-09 01:06:40 UTC
Created attachment 144046 [details]
Menu icons 6.1
Comment 28 Robert Berg 2018-08-09 04:12:13 UTC
The icons that still look good in my screenshots of 6.1, they are still going bad one or two at a time with each relaunch of the program. I will provide any further information needed to help resolve this issue. Just let me know what you need.
Comment 29 Daniel C Scearce 2018-08-11 15:36:20 UTC
For anyone having this problem on Windows, you can simply disable cache as a hack-fix:

1) delete everything in %appdata%\Roaming\LibreOffice\4\cache
2) go to Properties -> Security -> Advanced for the cache folder, disable Inheritance.
3) remove all permissions from your own username from the cache folder.

Then wait until someone with the programming skills actually fixes this bug.

-Daniel
Comment 30 Trevor R 2018-08-14 09:05:56 UTC
Maybe this will help to narrow things down... I have a Windows 10 High DPI laptop (scaled to 200%). I have it hooked up to a 100% scaled (normal DPI) display using extended display option in Windows. On initial totally clean install of LibreOffice 6.1, everything was fine. I could close and restart LibreOffice as much as I want and move it to HiDPI display and all the icons look fine (no black-out/broken icons).

If however I load LibreOffice with only the High DPI display (no second normal DPI monitor connected), then I get the broken icons. 

But what's odd is as soon as I connect the second display again, then re-open LibreOffice, the icons are fine again on both monitors.
Comment 31 Robert Berg 2018-08-14 09:14:09 UTC
I also have a second display hooked to my machine, but it has 150% scaling set and LibreOffice still has the broken icons.
Comment 32 Robert Berg 2018-09-06 18:04:09 UTC
All the icon themes except Sifr seem to be corrupted on second and subsequent launches after changing to that icon theme. For users impacted by this bug, that want a quick fix until resolved, go to Tools -> Options, then in Options go to LibreOffce -> View, then set Icon Style to Sifr (Sifr Dark has the same corruption issues, you must use Sifr). Maybe the devs can also use the knowledge that the Sifr icons do not suffer the corruption as a starting point to track down the bug.
Comment 33 V Stuart Foote 2018-10-05 15:03:15 UTC
closing this duplicate of bug 119020 which has more complete testing and code points.

This is not a HiDPI hardware issue, just mishandling of the icon rendering when setting the Windows DE "scaling settings" above 125% (which triggers loadFromSVG() rebuild of the icon cache).

*** This bug has been marked as a duplicate of bug 119020 ***