Bug 117674 - 'Open' and 'Open Remote' icons (both in Launcher sidebar and drop down menus) are in High Contrast mode and glitchy.
Summary: 'Open' and 'Open Remote' icons (both in Launcher sidebar and drop down menus)...
Status: RESOLVED DUPLICATE of bug 119020
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Icon-Themes
  Show dependency treegraph
 
Reported: 2018-05-17 20:58 UTC by Robert Berg
Modified: 2018-10-05 15:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of side bar icons (377.40 KB, image/jpeg)
2018-05-17 21:08 UTC, Robert Berg
Details
Screenshot of drop down menu icons (104.28 KB, image/jpeg)
2018-05-17 21:10 UTC, Robert Berg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Berg 2018-05-17 20:58:42 UTC
The 'New' and 'Open' icons display as though the icons are set to High Contrast mode, even when the rest of the icons are fine. The 'New' and 'Open' icons also look glitchy. This problem appears in the LibreOffice "Launcher" sidebar, and in the drop down menus, but only appears to affect the 'New' and 'Open' icons. This problem has been present since LibreOffice 6.0, and is happening on three systems I own, all running Windows 10 64-bit. The icons in question function normally, but it really detracts from the UI, and uninstalling and reinstalling LibreOffice does not fix the issue.
Comment 1 Robert Berg 2018-05-17 21:02:49 UTC
Sorry, it is the 'Open' and 'Open Remote' icons.
Comment 2 Robert Berg 2018-05-17 21:08:35 UTC
Created attachment 142173 [details]
Screenshot of side bar icons

Screenshot of the "Launcher" sidebar, with the icons in question.
Comment 3 Robert Berg 2018-05-17 21:10:00 UTC
Created attachment 142174 [details]
Screenshot of drop down menu icons

Screenshot of the drop down 'File' menu, with the icons in question.
Comment 4 Adolfo Jayme 2018-05-18 20:14:45 UTC
Just speculating (since I can’t reproduce this and can’t test in Windows ATM), but it may have something to do with the compression I applied to those icons when I last updated them. If you can only reproduce this problem with the Tango theme, then this is a low-pro: we’re replacing Tango with Colibre for our next major release, 6.1.

Do you have OpenGL rendering enabled in Options? Does disabling it help?
Comment 5 Robert Berg 2018-05-18 20:24:52 UTC
OpenGL and OpenCL are off. As for themes, I don't see a Tango or Colibre, I just see the Firefox Themes under Personalization, and there I have selected "Default look, don't use themes".
Comment 6 Adolfo Jayme 2018-05-19 13:50:59 UTC
Thanks for checking your OpenGL setting! (OpenCL is a different matter entirely, and isn’t related to this issue).

Also, when mentioning Tango and Colibre, I was talking about our icon themes, not Firefox Personas. Colibre will debut with 6.1, so you won’t find it in 6.0.x or any previous version.
Comment 7 Buovjaga 2018-06-20 18:45:56 UTC

*** This bug has been marked as a duplicate of bug 114699 ***
Comment 8 V Stuart Foote 2018-10-05 15:04:21 UTC
QA housekeeping

*** This bug has been marked as a duplicate of bug 119020 ***