Bug 114727 - Problems signing document/PDF doesn't work/hangs
Summary: Problems signing document/PDF doesn't work/hangs
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Digital-Signatures
  Show dependency treegraph
 
Reported: 2017-12-28 10:55 UTC by Marco A.G.Pinto
Modified: 2018-02-28 14:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
signing certificates (9.88 KB, image/png)
2017-12-28 10:55 UTC, Marco A.G.Pinto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marco A.G.Pinto 2017-12-28 10:55:51 UTC
Created attachment 138709 [details]
signing certificates

This never seems to work in versions before 6.0 RC1 and it still doesn't work.

Take a look at the screenshot submitted: it has an expired certificate that seems to come with LO. Then, it has my key whose expire date is 00-00-0000 (it should show "Never" instead of that).

Then, signing a document that only has the text "123" spends hours with the mouse pointer busy and never ends.

I believe I tried to sign a PDF with 6.0 RC1 and it doesn't work.
Comment 1 Marco A.G.Pinto 2017-12-28 10:58:48 UTC
Before I forget: LO says there is no "Certificate Manager blah blah" when I have installed Gpg4win 3.0.2 which has Kleopatra.
Comment 2 Timur 2018-02-28 14:07:43 UTC
As for expired certificate, I wrote in Bug 113190. You may follow.
As for expire date is 00-00-0000, there's no reason to put never to this field type so it's WontFix.
As for "signing a document that only has the text "123" spends hours" no repro. If you want this to be in this bug, you need to write reproducible steps. Since we cannot request certificates like we request documents, it would be helpful that you test with master http://dev-builds.libreoffice.org/daily/master/ as I requested. Also screencast of what you do or attach a zipped series of screenshots. And write which exactly is certificate you use. If you still repro that with master, please set back to Unconfirmed.
As for Comment 1, I reported as Bug 116085. You may follow.

Whole report is Invalid because it mixes different issues.