Download it now!
Bug 114795 - Calc freezes on table paste.; wrong import of table from webpage
Summary: Calc freezes on table paste.; wrong import of table from webpage
Status: RESOLVED DUPLICATE of bug 91237
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.6.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-01 22:08 UTC by Ryan Johnson
Modified: 2018-01-25 11:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Johnson 2018-01-01 22:08:16 UTC
Description:
Copied the large table on this website, and pasted into LibreOffice Calc. Calc froze up for several minutes. The app icon kept flickering on the windows taskbar indicating the process might be frozen.

It finally pasted after way too long. And it pasted in incorrect format. The source table is only 6 columns wide. The pasted table goes out all the way to the RF column, and each row has an additional column in it, indicating a procedural error in the paste procedure or HTML parse procedure.

http://leagueoflegends.wikia.com/wiki/List_of_Champions

Steps to Reproduce:
1. Copy the table of champions http://leagueoflegends.wikia.com/wiki/List_of_Champions
2. Paste into Calc spreadsheet. If it makes a difference, I pasted into Sheet2.
3. Wait.

Actual Results:  
Calc froze up for several minutes. The app icon kept flickering on the windows taskbar indicating the process might be frozen.

It finally pasted after way too long. And it pasted in incorrect format. The source table is only 6 columns wide. The pasted table goes out all the way to the RF column, and each row has an additional column in it, indicating a procedural error in the paste procedure or HTML parse procedure.

Expected Results:
Pastes the table as displayed on the website.


Reproducible: Didn't try


User Profile Reset: No



Additional Info:
OpenGL Extensions Viewer does not indicate whether OpenGL is enabled. It gives a version number: 4.6.


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Xavier Van Wijmeersch 2018-01-02 06:38:08 UTC
no repro

Version: 5.3.1.2
Build ID: e80a0e0fd1875e1696614d24c32df0f95f03deb2
CPU Threads: 8; OS Version: Linux 4.9; UI Render: default; VCL: kde4; Layout Engine: new; 
Locale: nl-BE (en_US.UTF-8); Calc: group

Version: 5.3.8.0.0+
Build ID: 7f1297d9b4f449eb9ada8008fb21b7046d1a8f19
CPU Threads: 8; OS Version: Linux 4.9; UI Render: default; VCL: kde4; Layout Engine: new; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-5-3, Time: 2017-11-10_15:56:34
Locale: nl-BE (en_US.UTF-8); Calc: group
Comment 2 raal 2018-01-02 19:18:18 UTC
I can confirm with LO 6.1 and 5.0 , Linux. I suppose the freeze is because LO reads images from website, I think it's not a bug. But imported table is wrong.
Comment 3 Timur 2018-01-03 11:57:27 UTC
For freeze on table paste there are already bugs like Bug 43338 or Bug 91237. So this looks like a duplicate. Please search before reporting. 
If I remember, issue was opening separate connection for each link.

As for this table, no freeze for me on a fast connection. But I don't get icons, can't say why. 

There can be no multiple issues per bug. 
As for "imported table is wrong" this bug could be about it if explained what exactly: "Copy the table of champions from.... to ...".
I copied from Champion to 880 and paste was fine, 6 columns. 

So, set to New was premature in my opinion.
Comment 4 Xisco Faulí 2018-01-25 11:54:33 UTC

*** This bug has been marked as a duplicate of bug 91237 ***