Bug 91237 - CALC hangs on web table paste (intermittent)
Summary: CALC hangs on web table paste (intermittent)
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected)
Hardware: Other Windows (All)
: high major
Assignee: Not Assigned
Keywords: haveBacktrace
: 114795 (view as bug list)
Depends on:
Blocks: Paste
  Show dependency treegraph
Reported: 2015-05-12 11:16 UTC by Timur
Modified: 2020-06-12 19:15 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:

Backtrace with "kb" (22.53 KB, text/plain)
2015-05-12 11:16 UTC, Timur
Backtraces from Libo Dev_5.2.0.0.alpha0 (3.86 KB, text/plain)
2015-12-22 17:46 UTC, Timur

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2015-05-12 11:16:35 UTC
Created attachment 115517 [details]
Backtrace with "kb"

Copying from Bug 89594:

Pasting from the following web page crashes calc:
2nd Table entitle 'All Countries'

Reproduced with LO 4.4.0 beta 2 (beta 1 doesn't seem to hang) and 5.0 alpha. 
Backtrace taken with "kb" because "analyze" not available after ntdll!NtTerminateProcess.

Bug 45307 doesn't seem related by the version, although the title is similar.
Comment 1 Timur 2015-05-12 11:18:36 UTC
I couldn't reproduce it in Ubuntu 15.04 with LO (automatic import options). Paste is rather slow but no hang.
Comment 2 raal 2015-05-12 12:05:34 UTC
I can confirm crash with LO 4.4.2, win7

Error message:   osl::Thread::create failed
Comment 3 Timur 2015-06-16 14:38:54 UTC still crashes:
Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	soffice.bin
  Application Version:
  Application Timestamp:	5578d67f
  Fault Module Name:	MSVCR110.dll
  Fault Module Version:	11.0.51106.1
  Fault Module Timestamp:	5098858e
  Exception Code:	40000015
  Exception Offset:	000a327c
  OS Version:	6.1.7601.
  Locale ID:	4122

5.0 beta3 crashes after:
loading component library mergedlo.dll failed

master~2015-06-16_07.04.09_LibreOfficeDev_5.1.0.0.alpha1_Win_x86 doesn't crash and behaves like Linux, paste is rather slow but there's no hang.

So, whatever changed, should be backported to 4.4 and 5.0.
Comment 4 Timur 2015-07-16 15:02:41 UTC still crashes 64-bit didn't crash
master LibreOfficeDev_5.1.0.0.alpha1_Win_x86 doesn't crash (mostly, there was one osl::Thread::create failed, but I couldn't reproduce)

So, since it's unlikely that 4.4 will be fixed, I'll close as WFM, at least until some duplicate is found.
Comment 5 kie000 2015-08-09 16:12:12 UTC
Tried with calc - data copied from firefox.

I just repeated the actions from my original comment and calc hung (with no error message), the data appeared to paste in but then Calc wouldn't do anything after that. Recovery did not recover anything.

Tried to copy same info from IE 11 got message 'contents of the clipboard could not be pasted. Data pasted into notepad fine though.
Comment 6 kie000 2015-08-09 16:15:35 UTC
Ps, copying half of the table works so this seems to be a size / buffer / memory problem. (I have 16GB so it's not that)
Comment 7 kie000 2015-08-09 16:20:56 UTC

4th attempt and it copied ok so bug is intermittent.

Odd thing is that calc freezes but it's not using the CPU.
Comment 8 Timur 2015-09-08 13:32:55 UTC
Version is earliest where reporduced. Reopen is when fix doesn't work, so New here.
Comment 9 Timur 2015-12-22 17:46:29 UTC
Created attachment 121501 [details]
Backtraces from Libo Dev_5.2.0.0.alpha0

component context fails to supply service com.sun.star.linguistic2.LinguServiceManager of type com.sun.star.linguistic2.XLinguServiceManager2: loading component library
<file:///S:/LO-00-parallel/master/program/../program/mergedlo.dll> failed
Comment 10 Xisco Faulí 2016-09-13 09:53:43 UTC
I guess this can be bibisected with this repository:
Adding keyword 'bibisectRequest'.
Comment 11 raal 2017-05-24 14:57:40 UTC
I cannot reproduce with version Could you retest?
Comment 12 Timur 2017-05-24 16:01:56 UTC Comment hidden (obsolete)
Comment 13 Timur 2017-05-24 16:03:31 UTC
Hard to say. Repro on 5.2.7. 
Then on first run crash on 5.3.3: http://crashreport.libreoffice.org/stats/crash_details/2fa53b4b-4484-4c5f-8f3e-33019591b5da but with Signature: atio6axx.dll (and OpenGL was off) so not sure whether related to this, because subsequent pastes were OK. 
And then crash without report on 5.5+ master master~2017-05-23_00.14.17_LibreOfficeDev_5.5.0.0.alpha0_Win_x86, but on second trial slow paste but no crash. All LO 32-bit.
Also with x64 http://crash crashreport.libreoffice.org/stats/crash_details/17c40d68-19d2-4d72-b1da-2ecca8e2ff68 with master~2017-04-13_00.34.50_LibreOfficeDev_5.4.0.0.alpha0_Win_x64_en-US_de_ar_ja_ru_qtz but Signature: mergedlo.dll.
Comment 14 Telesto 2017-07-08 12:25:52 UTC
No crash pasting from Firefox with
Build ID: cac5c9f6081590b0548d3116bc4cd4a2509ec576
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-07-01_00:41:48
Locale: it-IT (nl_NL); Calc: CL

Pasting is a bit slow. And strange focus issues (LibO goes to the background a few times)
Comment 15 Xavier Van Wijmeersch 2017-07-08 16:27:03 UTC
i have no crash when paste to writer or calc, while pc is at 100% running because of building a new LO dev 6.0alpha+

Build ID: 6549993b17feb1423c76b5237f086e6f35346a2c
CPU threads: 8; OS: Linux 4.9; UI render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-07-06_07:37:37
Locale: nl-BE (en_US.UTF-8); Calc: group
Comment 16 Xisco Faulí 2018-01-25 11:54:33 UTC
*** Bug 114795 has been marked as a duplicate of this bug. ***
Comment 17 Buovjaga 2018-05-17 11:08:25 UTC
I was considering bibisecting this, but I don't get a hang. It is true that it is a bit slow.

Timur: can you re-test and possibly close?

Linux is similarly slow, so I guess I could do a callgrind trace and add to a new report about perf.

Build ID: 23c5125148a8110d88385b29570bf0b7d4400458
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-05-12_00:15:25
Locale: fi-FI (fi_FI); Calc: group
Comment 18 Buovjaga 2018-05-17 11:50:00 UTC
Opened bug 117667 about the perf. Confirmed it goes back to 3.3
Comment 19 Timur 2018-05-17 15:08:47 UTC
Win 7, first time open:

LO 5.3.7 32-bit dump, slow and Fatal Error: 
component context fails to supply service
com.sun.star.linguistic2.LinguServiceManager of type
com.sun.star.linguistic2.XLinguServiceManager2: loading component library

LO 5.4.7 64-bit dump, slow

LO 6.0.4 32-bit dump, slow, "LibreOffice stopped working" APPCRASH ucrtbase.DLL (no LO Crash report)

LO 6.1+ 32-bit dump, slow (not responding for a while until it comes back)

6ae9aaf3 83e800          sub     eax,0

I'm not sure should we close this one. Now we have crash in 6.0.4 and no crash in master, but dump is still there. Probably the cause is somewhere else. 

I guess it's an old problem, maybe of multiple connections fetching data, icons that are linked to web location.
Telesto also wrote "It seems to me that LibO is trying to download every image at once, creating a flood of TCP connections (I used TCPview)".
We had this discussed somewhere long time ago, can't find it.
That's why I'm not in favor of the new bug 117667 about the perf.
Comment 20 Timur 2018-05-17 15:32:45 UTC
Correction: it's See also Bug 43338.
Comment 21 QA Administrators 2019-05-18 03:05:54 UTC Comment hidden (obsolete)
Comment 22 Buovjaga 2020-06-12 12:40:32 UTC
I used this old revision of the page and did some testing: https://en.wikipedia.org/w/index.php?title=List_of_countries_by_renewable_electricity_production&oldid=669204573

Win 4.4 bibisect repo and 5.0 repo: no crash or hang. 7.1 doesn't hang either. Just takes a bit of time.
Comment 23 Timur 2020-06-12 14:14:45 UTC
I reproduced crash Windows with LO 4.4.7, not with 6.0.7 and 7.1+.
I didn't look for hang, I find it valuable but nobody fixes them.
So let me close.
Comment 24 kie000 2020-06-12 15:27:35 UTC
i7 3770K, 16GB ram, ssd, fast wired internet, Win7 64bit

Libreoffice 6.04.0004.0002

Hangs for me (not crashes, just frozen), currently been over 15 minutes. The system is idling, CPU usage ~1%, memory at 49% usage etc

I can only guess LibreOffice is waiting for something that isn't going to happen, perhaps over and over again.

I'm going to kill the process and try again with Libreoffice 7 beta1
Comment 25 kie000 2020-06-12 15:54:03 UTC
i7 3770K, 16GB ram, ssd, fast wired internet, Win7 64bit

LibreOffice 7 beta-1 also hang/freezing,

Copies from Waterfox and Slimjet (firefox and chrome based respectively) both cause hangs. 

LibreOffice 6 and 7 both refuses to paste from internet explorer copy - "The contents of the clipboard could not be pasted."

/Not resolved
Comment 26 kie000 2020-06-12 16:23:22 UTC
Tried on another win7 system LibreOffice 7b1 pasted from Slimjet (chrome fork) and it took a whilst but succeeded.

So perhaps a fresh win7 install on my main machine would fix the problem, in the meantime if I'm desperate to paste a big table from the web then my slow laptop can do it!
Comment 27 Timur 2020-06-12 18:54:23 UTC
Based on previous report, we should maybe reopen. But it makes sense only if some test can be done to show what's going on. Xisco, please advise.
Comment 28 Buovjaga 2020-06-12 19:15:21 UTC
(In reply to Timur from comment #27)
> Based on previous report, we should maybe reopen. But it makes sense only if
> some test can be done to show what's going on. Xisco, please advise.

But we have bug 45307 still open.