Bug 114824 - Export to PDF and Printing: Borders of Merged Cells Flow to Page Footer
Summary: Export to PDF and Printing: Borders of Merged Cells Flow to Page Footer
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.0.1 rc
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 115555 (view as bug list)
Depends on:
Blocks: borderline-regressions
  Show dependency treegraph
 
Reported: 2018-01-03 15:39 UTC by Kevin Suo
Modified: 2018-02-08 18:22 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
pdf for the skipped commit sha:a9c59cbfb9e1 (13.04 KB, application/pdf)
2018-01-03 16:38 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2018-01-03 15:39:05 UTC
Attachment 138404 [details] contains merged cells which span over two pages. When export to PDF or printed, the left-bottom part of the borders for the merged cells appear at the footer part of the page.

Steps to reproduce:
1. Export attachment 138404 [details] as pdf.

Current Result:
see attachment 138405 [details].

Expected:
see attachment 138406 [details].

It works in libreoffice 5.4 but is broken in 6.0.

Version: 6.1.0.0.alpha0+
Build ID: 6a29d733651eb307ee8a6c3cf1bc64579070e53a
CPU threads: 4; OS: Linux 4.14; UI render: default; VCL: gtk3; 
Locale: zh-CN (zh_CN.UTF-8); Calc: group threaded

Adding bug 113751 as see also.
Comment 1 Kevin Suo 2018-01-03 16:35:08 UTC
git bisect log
# bad: [cddc6665c4e33f5a18e7e1a02cd2799d95653f0a] source sha:47cc374c0659fd3db74a1b184c870eaa56bc385b
# good: [b9d78ce81dc3481fccb0cb75d76fcb6ac939cbd5] source sha:9feb7f7039a3b59974cbf266922177e961a52dd1
git bisect start 'master' 'oldest'
# good: [eb6680d85befc418b36f2cb00402f56a2472758f] source sha:c54850b23a8240a41755af171a6d3f990ee69f84
git bisect good eb6680d85befc418b36f2cb00402f56a2472758f
# bad: [3fa1ae98ece9b3537df34742d3383aac834caf76] source sha:87c671d188f4a0f5dcc7944b450cc58e84217d81
git bisect bad 3fa1ae98ece9b3537df34742d3383aac834caf76
# bad: [9d2ea57d07b47b50f78eaa47639d417ce2c98c18] source sha:bf0996d39cbb0162c037ae1c9037e8c0f9d5b0e7
git bisect bad 9d2ea57d07b47b50f78eaa47639d417ce2c98c18
# good: [43ab4aa986eb256c5ad570a2e7c82018d056eb37] source sha:1a2b33348e53a4c3262494cfc5bfa7cbd1bb4e36
git bisect good 43ab4aa986eb256c5ad570a2e7c82018d056eb37
# bad: [2e30f808d4b0937cc3d997468ed785ddb351ae46] source sha:49585b5bac0ee3861afbde779a0d3b380421d264
git bisect bad 2e30f808d4b0937cc3d997468ed785ddb351ae46
# bad: [2ed6c20a686cf3c3d45211952c0360624e88523f] source sha:e564aff1f064ce157643978ff9231808095c43a5
git bisect bad 2ed6c20a686cf3c3d45211952c0360624e88523f
# good: [3a1946e84ea1ead6d182fe5a55671c99850f50d9] source sha:871d75e9c2c82d4b3ffbbff80f1dfa7a823e4f3d
git bisect good 3a1946e84ea1ead6d182fe5a55671c99850f50d9
# bad: [453fb5540f7de6c8f2f8a50735db263e6716e224] source sha:7282b25f226bf73ed88dbd3d0a6f265f1626d190
git bisect bad 453fb5540f7de6c8f2f8a50735db263e6716e224
# bad: [e4982418b364315f649d2f1e15ac6656664786a4] source sha:ab65fe804cf3a97bd172b5551b553b9bcde6d756
git bisect bad e4982418b364315f649d2f1e15ac6656664786a4
# good: [9c30daa231889fdc9860f9ef07e5969bda068816] source sha:5d060fd07a16c80bd94d27b08fefe1d0aaf418f7
git bisect good 9c30daa231889fdc9860f9ef07e5969bda068816
# good: [f08dfefaa748eba5744f1e15eebcd225503276c3] source sha:596efaad51735a130e7b7bd27dbc34dc07f32f68
git bisect good f08dfefaa748eba5744f1e15eebcd225503276c3
# skip: [2eba19601133f0ebb6e23c8bf6f6962f0b11ee74] source sha:a9c59cbfb9e16469b389db0b4d6befe196d0e2a0
git bisect skip 2eba19601133f0ebb6e23c8bf6f6962f0b11ee74
# bad: [7aa1b7635a4ee01276f4bac5a43d089b8a3d61ee] source sha:2f16219741aba016677103e4b22738d055c39a91
git bisect bad 7aa1b7635a4ee01276f4bac5a43d089b8a3d61ee
# good: [eb00407a2e67601dd5db7973d8a20c3adeb73023] source sha:fe14ddf25003c0f79f9f8a249bc22d45f57a0068
git bisect good eb00407a2e67601dd5db7973d8a20c3adeb73023
# only skipped commits left to test

# possible first bad commit: [7aa1b7635a4ee01276f4bac5a43d089b8a3d61ee] source sha:2f16219741aba016677103e4b22738d055c39a91
# possible first bad commit: [2eba19601133f0ebb6e23c8bf6f6962f0b11ee74] source sha:a9c59cbfb9e16469b389db0b4d6befe196d0e2a0

It should be mentioned that, in the only skipped commit, source sha:a9c59cbfb9e1, the borders seems weird. And then in commit source sha:2f16219741ab the weird preview is gone but the bug I described appear.

author	Armin Le Grand <Armin.Le.Grand@cib.de>	2017-09-14 11:44:23 +0200
committer Armin Le Grand <Armin.Le.Grand@cib.de>	2017-09-15 12:58:04 +0200
commit	2f16219741aba016677103e4b22738d055c39a91 (patch)
tree	55a3ab0dc313b4eb28893970c10b1732658e7e89
parent	16fd7af90a9be159ebc7eab09083f1ef7eb64645 (diff)
borderline: Fixed PatternScale
The applied PatternScale factor was not consequently used in
svx::frame::Style so that the Previews in the Dialogs look weird.
Fixed that and stumbled over Writer applying it's own scale
which then was leading to double scaling, ceaned that up.

Adding cc Armin Le Grand.
Comment 2 Kevin Suo 2018-01-03 16:38:13 UTC
Created attachment 138857 [details]
pdf for the skipped commit sha:a9c59cbfb9e1
Comment 3 Xisco Faulí 2018-01-25 10:08:40 UTC
Moving to NEW
Comment 4 Armin Le Grand (CIB) 2018-02-06 18:31:12 UTC
Fixed with changes for tdf#114934, see there
Comment 5 Xisco Faulí 2018-02-08 18:22:43 UTC
*** Bug 115555 has been marked as a duplicate of this bug. ***