Bug Hunting Session
Bug 114846 - Checkbox in opened PDF isn't shown as checkbox
Summary: Checkbox in opened PDF isn't shown as checkbox
Status: RESOLVED DUPLICATE of bug 101220
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering PDF-Import-Draw
  Show dependency treegraph
 
Reported: 2018-01-05 11:38 UTC by Aron Budea
Modified: 2018-01-07 15:06 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2018-01-05 11:38:29 UTC
Open attachment 138893 [details] from bug 114844 in Draw, and look at the checkboxes.

=> They aren't shown as checkboxes (see screenshot in attachment 138894 [details]).

The text layout issue is different, and has been reported in bug 114844.

Observed using LO 6.1 master build (a0e136d2cbb3784ddfcbddcfed5d784c8e4c9a64) & 4.2.0.4 / Ubuntu 17.04.
Nothing is shown in place of the checkboxes in 4.1.0.4.

The first time the checkboxes are rendered (incorrectly) is after this commit:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=eb276d11a652601f743d69ada7a38016bd97d73e
author		Fridrich Štrba <fridrich.strba@bluewin.ch>	2013-07-08 14:01:17 +0200
committer	Fridrich Strba <fridrich@documentfoundation.org>	2013-07-08 16:25:32 +0000

"fdo#38878: Upgrading internal xpdf -> poppler"

Evince, also relying on poppler displays the checkboxes fine.
Comment 1 V Stuart Foote 2018-01-05 16:19:32 UTC
From 5.4.0 the pdfium based insert as image correctly handles the checkbox.

But the pdfio filter import to Draw does not. And, on import if you select the checkbox and paste it into Writer--the font is listed as "Wingdingsular" and the code point (from Alt+X conversion) is U+0086

The embedded subset fonts of the PDF do not list "Wingdingsular" as a font--so maybe it was supposed to be the embedded Wingdings Regular?  

And, as a result of the bad naming, the font and the codepoint are handled by system font fallback.  And since U+0086 is a control codepoint--most fonts will have no coverage giving a bogus replacement

Depending on a malformed font, on Windows 10 I get a substitution using the placeholder glyph--and it looks like it is Segoe UI.

I'd suspect the text layout issues are likewise result of bad fallback font selection for one of the embedded PalatinoLinoType weights.
Comment 2 V Stuart Foote 2018-01-07 15:06:43 UTC

*** This bug has been marked as a duplicate of bug 101220 ***