Download it now!
Bug 114861 - Digital Signatures don't appear after choosing a certificate from the "certificate dialog"
Summary: Digital Signatures don't appear after choosing a certificate from the "certif...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Digital-Signatures
  Show dependency treegraph
 
Reported: 2018-01-06 14:07 UTC by Oliver Ostertag
Modified: 2018-03-02 10:41 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Digitale Signatur Dialog (8.51 KB, image/png)
2018-01-06 14:11 UTC, Oliver Ostertag
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Ostertag 2018-01-06 14:07:58 UTC
Description:
see step by step explanation

Steps to Reproduce:
German Version:
1. Open "Datei / Digitale Signaturen / Digitale Signaturen"
2. press the "Dokument signieren" (sign document) button
3. choose a valid certificate and press "ok"
4. the certificate does not appear ...

Actual Results:  
the certificate which has been choosen does not appear in the dialog as exspected

Expected Results:
the choosen certificate should appear


Reproducible: Always


User Profile Reset: Yes



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Oliver Ostertag 2018-01-06 14:11:39 UTC
Created attachment 138916 [details]
Digitale Signatur Dialog
Comment 2 Julien Nabet 2018-01-29 17:55:27 UTC Comment hidden (obsolete)
Comment 3 Timur 2018-02-02 16:06:28 UTC
No repro in Windows 7.
There's also work in progress like Bug 83877.
If 5.4.4 is also repro please try also with master http://dev-builds.libreoffice.org/daily/master/ like http://dev-builds.libreoffice.org/daily/master/Win-x86_64@42/current/ that will not spoil your LO.
Comment 4 Oliver Ostertag 2018-02-04 14:17:13 UTC
I can reproduce the bug with LO 5.4.4

It is still as described at 2018-01-06 14:07:58 UTC, see description and attached Screenshot.

Changed Status from "NEEDINFO" to "UNCONFIRMED".
Comment 5 Timur 2018-02-28 12:55:28 UTC
Bug needs to be reproducible to be confirmed. 
Since we cannot request certificates like we request documents, it would be helpful that you test with master http://dev-builds.libreoffice.org/daily/master/ as I requested. 
Please make screencast of what you do or attach a zipped series of screenshots. 
And write which exactly is certificate you use.
Comment 6 Oliver Ostertag 2018-02-28 18:50:17 UTC
I can not reproduce the bug anymore. Maybe it was an issue with one of my other old expired certificates which have been deleted now. Changed Status to "RESOLVED (NOT A BUG)".
Comment 7 Timur 2018-03-02 10:41:43 UTC
When there was a bug but not anymore, it's WorksForMe.
NotABug is when an issue never was a bug.
Anyway, thanx.