Bug 114880 - Formatting: Clone Formatting tool broken on paragraph properties
Summary: Formatting: Clone Formatting tool broken on paragraph properties
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: Clone-Formatting
  Show dependency treegraph
 
Reported: 2018-01-07 12:34 UTC by Michael H.
Modified: 2020-10-18 04:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael H. 2018-01-07 12:34:59 UTC
Description:
When using the Clone Formatting tool to clone paragraph properties (e.g., indention, alignment, lists, tab stops, line spacing), none are cloned.


Steps to Reproduce:
1. Select the Clone Formatting tool when cursor is in a paragraph (source) having any of these properties: indented, bulleted, numbered, defined tab stops, multiple line-spacing.
2.Apply the Clone Formatting tool to a normal paragraph (target) having none of the above properties.

Actual Results:  
The target paragraph does not change in any way.

Expected Results:
The target paragraph acquires all the properties of the source paragraph


Reproducible: Always


User Profile Reset: Yes



Additional Info:
When saving the properties in a user-defined Style, the Style can also not be cloned to the target paragraph.
Cloning does work on out-of-the-box Styles.


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 Mike Kaganski 2018-01-07 13:00:02 UTC
https://helponline.libreoffice.org/latest/en-US/text/shared/guide/paintbrush.html?DbPAR=SHARED

> By default only the character formatting is copied ; to include paragraph formatting,
> hold down Ctrl when you click. To copy only the paragraph formatting, hold down
> Ctrl+Shift when you click.
Comment 2 Michael H. 2018-01-07 13:06:14 UTC
Wow. Seriously, since when?

It was reported as a bug on 5.2 and the bug case was never updated.

Well, I'll take care of that now.

Thanks!
Comment 3 Mike Kaganski 2018-01-07 13:23:29 UTC
(In reply to Michael H. from comment #2)
> Wow. Seriously, since when?

Since 4.1 (see bug 59029).
Comment 4 Michael H. 2018-01-07 13:32:12 UTC
Thanks, Mike!

I'm surprised to learn how long ago this has been implemented. I just lived with the presumed bug since 5.4., seeing that it was not being handled.

I wholeheartedly agree with the comment made by Kevin on that change. https://bugs.documentfoundation.org/show_bug.cgi?id=59029#c18