Download it now!
Bug 114907 - [NEW HELP] Contents folder symbol not rendered in Windows 7
Summary: [NEW HELP] Contents folder symbol not rendered in Windows 7
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
6.0.0.1 rc
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.1.0
Keywords:
Depends on:
Blocks: New-Help
  Show dependency treegraph
 
Reported: 2018-01-08 11:56 UTC by Olivier Hallot
Modified: 2018-01-16 16:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Icons in Contents div not rendered (24.93 KB, image/png)
2018-01-08 11:56 UTC, Olivier Hallot
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Hallot 2018-01-08 11:56:41 UTC
Created attachment 138959 [details]
Icons in Contents div not rendered

Since 

https://gerrit.libreoffice.org/gitweb?p=help.git;a=commitdiff;h=382ba1bc41a04d2f7b444e4c4ca9460b66147717

the Contents div folder icon changed from an icon to a Unicode character.

However the character does not render in default Windows 7 fonts with IE11.

See image attached.

Reverting to icon will fix it.
Comment 1 V Stuart Foote 2018-01-08 19:13:10 UTC
The glyph for Web use maybe should be Unicode 1f4c1 codepoint, rather than 1f5bf (both covered in the Segoe UI Symbol at Windows 10).

Since LO deploys both Noto Emoji and EmojiOne Color, with coverage of 1f4c1 in both, we should be OK with the Unicode glyphs rather than reverting to an Icon.

Also, the 1f4c1 glyph from Segoe UI Symbol should be available on Windows 7/7 SP1 systems with KB279074 installed. Just not the 1f5bf
Comment 2 Buovjaga 2018-01-09 07:07:38 UTC
(In reply to V Stuart Foote from comment #1)
> The glyph for Web use maybe should be Unicode 1f4c1 codepoint, rather than
> 1f5bf (both covered in the Segoe UI Symbol at Windows 10).
> 
> Since LO deploys both Noto Emoji and EmojiOne Color, with coverage of 1f4c1
> in both, we should be OK with the Unicode glyphs rather than reverting to an
> Icon.
> 
> Also, the 1f4c1 glyph from Segoe UI Symbol should be available on Windows
> 7/7 SP1 systems with KB279074 installed. Just not the 1f5bf

Ok, that would be KB2729094. The problem is, 1f4c1 and 1f4c2 have a silly 3D perspective style in many fonts.

https://www.compart.com/en/unicode/U+1F4C1
https://www.compart.com/en/unicode/U+1F4C2
Comment 3 Buovjaga 2018-01-14 15:06:14 UTC
Proposal: let's forget the folder and use squared plus and minus:
https://www.fileformat.info/info/unicode/char/229e/index.htm
https://www.fileformat.info/info/unicode/char/229f/index.htm

So .contents-treeview label::before has content: "⊞"
and .contents-treeview input:checked + label::before has content: "⊟";

These have been in Unicode since 1993 and should have wide support.

It brings a nice and familiar interactive UI touch.

Note that next to Index, we use this, which is from 2010: http://www.fileformat.info/info/unicode/char/1F50E/index.htm
I guess we got lucky so far.
I did notice in a very spartan NixOS virtual machine that Midori displayed a square in its place.
Comment 4 Commit Notification 2018-01-15 15:11:38 UTC
Ilmari Lauhakangas committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=ff44bbe7087cf87977103627f55a8b1b5c9ffb89

tdf#114907 Expand and collapse symbols for Contents