Bug Hunting Session
Bug 114935 - Document will lose focus after using the floating windows color picker
Summary: Document will lose focus after using the floating windows color picker
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.7.2 release
Hardware: All All
: medium normal
Assignee: Maxim Monastirsky
URL:
Whiteboard: target:6.1.0
Keywords:
Depends on:
Blocks: Color-Picker-Widget
  Show dependency treegraph
 
Reported: 2018-01-09 16:17 UTC by Telesto
Modified: 2018-08-13 18:33 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-01-09 16:17:15 UTC
Description:
The mean document will lose the active state (focus), when using the floating windows color picker.

Sidenote: many thanks to Maxim Monastirsky for re-introducing this feature! Quite happy with it :-) Bug 106762

Steps to Reproduce:
1. Open Writer
2. Type some text
3. Open the color picker and drag it to a separate position (Floating window) (notice the defocus)
5. Select the text typed before
6. Click on a color in the color picker. Press CTRL-U to underline (nothing happens, because focus is lost)


Actual Results:  
Focus lost when using the floating color window; not happening with a floating toolbar 

Expected Results:
The document should have focus like other toolbars


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
Version: 6.1.0.0.alpha0+
Build ID: a9b202a6b7000e7af34f2a639ca207122a3968bf
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-12-26_23:10:23
Locale: nl-NL (nl_NL); Calc: CL

and in
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL



User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Maxim Monastirsky 2018-01-10 08:33:56 UTC
https://gerrit.libreoffice.org/47690 is my attempt of fixing this.
Comment 2 Commit Notification 2018-01-17 01:08:27 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=27473d1c0f8ba3006262001cbefff33f639a19ac

tdf#114935 Move the focus back to the document

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Maxim Monastirsky 2018-01-17 01:15:48 UTC
The main document loses the focus already when the color picker is first opened by clicking the toolbar button. This can be verified by pressing arrow or tab keys. As can be seen, they're interpreted by the color picker, not by the document. It has nothing to do with turning the color picker into a floating window later. Note that this focus change is needed to support any keyboard handling inside floating windows, see Bug 87120 and Bug 104368, so we can't avoid it.

In fact, same behavior can be seen with any other toolbar, e.g. when you click into the font name or font size boxes of the Formatting toolbar, the focus moves to them, so it isn't possible to edit the document or apply shortcuts like CTRL+U. And if at this stage you undock the Formatting toolbar, the focus still won't be in the document, obviously because it wasn't there before. So really there isn't any difference in behavior between a floating color picker and other floating toolbars.

But, both the font name and font size boxes have a special code, which returns the focus to the document once the user finished his interaction with the control, by either selecting an entry from the dropdown list, or typing a font name/size and pressing Enter. This happens for both docked and floating toolbars. So my current patch tries to do the same with the color picker. So now after applying a color, it will force the focus back to the document.