Download it now!
Bug 114965 - LibreOffice v5.3.7 and v5.4.4 unusable after installation and security check on macOS High Sierra
Summary: LibreOffice v5.3.7 and v5.4.4 unusable after installation and security check ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.5.1 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-11 19:50 UTC by Fabien Auréjac
Modified: 2018-10-10 08:31 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabien Auréjac 2018-01-11 19:50:17 UTC
Security check from macOS High Sierra tells "LibreOffice.app is damaged and cannot be opened" after its installation and the installation of French locales.
Comment 1 Alex Thurgood 2018-01-12 07:59:36 UTC
@Fabien:

1) what are your Gatekeeper settings ?

2) Can you try running the following command from the Terminal and then attempt to start LibreOffice :


xattr -d com.apple.quarantine /Applications/LibreOffice.app


Please report back your findings here.
Comment 2 Alex Thurgood 2018-02-13 12:35:50 UTC
So, I could reproduce this with LO5451...

Note that I already had a functioning LO5432 with FR langpack.


1) I downloaded the main DMG plus the FR langpack.

2) I installed the main LO app bundle in the usual way, by drag and drop into the Applications folder. I authorized the installer to overwrite my existing LibreOffice.app

3) I then installed the langpack, and authorized it to install (admin password).

4) I then tried starting LibreOffice.app directly from the Applications folder via a double-click of the mouse.

5) At this point, an error message is displayed indicating that the installation is corrupt and that I should move the app to the trash.


WORKAROUND :
I removed LO and started again, however, this time, I started the main app bundle after its installation by right mouse button clicking on the app and choosing Open from the context menu, BEFORE installing the langpack. After closing the LO app launched for the first time, I then installed the langpack and restarted LO. Everything worked as normal by proceeding in this manner.
Comment 3 Alex Thurgood 2018-02-13 12:38:13 UTC
@cloph : there's something still not right here with the installation process, but I can't nail it down. When the langpack is installed, it is supposed to start LO for a first time - it did indeed appear to do this, as there is activity in the Dock, but launching LibreOffice.app from the Applications folder after this caused the "corrupt application" error message to appear.
Comment 4 Alex Thurgood 2018-02-13 13:02:45 UTC
So, if I check the app bundle with 

codesign -vvv /Applications/LibreOffice.app

/Applications/LibreOffice.app: a sealed resource is missing or invalid
file added: /Applications/LibreOffice 2.app/Contents/Resources/autotext/fr/crdbus50.bau

with the same message for the usual list of other files that get added when the langpack is installed
Comment 5 Alex Thurgood 2018-02-13 13:03:39 UTC
Gatekeeper is set to allow apps from the AppStore and identified developers.
Comment 6 Alex Thurgood 2018-02-13 13:06:40 UTC
(In reply to Alex Thurgood from comment #4)
> So, if I check the app bundle with 
> 
> codesign -vvv /Applications/LibreOffice.app
> 
> /Applications/LibreOffice.app: a sealed resource is missing or invalid
> file added: /Applications/LibreOffice.app/Contents/Resources/autotext/fr/crdbus50.bau

I should corrected the output above : LibreOffice 2.app to LibreOffice.app. I have several installations of LO under various names, but the problem remains the same irrespective of that.
Comment 7 Fabien Auréjac 2018-02-13 13:12:27 UTC
My Gatekeeper settings are :

"allow apps from the AppStore and identified developers"

LibreOffice 5.4.5.1 works again after entering the terminal command you provided.

Sorry for this late reply, i didn't see your follow up.

Fabien
Comment 8 Alex Thurgood 2018-10-10 08:31:05 UTC
Per comment 7, closing as WFM