Bug 103892 - macOS: Slow application start when using start center
Summary: macOS: Slow application start when using start center
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.2.1.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf, regression
: 114364 (view as bug list)
Depends on:
Blocks: MacOS-Performance
  Show dependency treegraph
 
Reported: 2016-11-12 19:41 UTC by Telesto
Modified: 2018-07-17 17:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
LLDB Backtrace with debug symbols (1.79 MB, text/plain)
2016-11-12 19:45 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2016-11-12 19:41:46 UTC
Description:
If a start an application, for example writer, from start center for the first time,  it's substantial slower in LO 5.2.1.2 (and up) compared to LO 5.2.1.1 (and lower)

Version: 5.2.1.1
Build ID: 2d75cf29e6d05e44c404f0547047f1da6563d380
CPU Threads: 4; OS Version: Mac OS X 10.12.1; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: group

Version: 5.2.1.2
Build ID: 31dd62db80d4e60af04904455ec9c9219178d620
CPU Threads: 4; OS Version: Mac OS X 10.12.1; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: group

Steps to Reproduce:
1. Open LibreOffice ('cold start')
2. Wait for Start Center
2. Start Writer (for example)
3. Take notice of the time launching

Actual Results:  
App launch takes around 8 seconds

Expected Results:
App launch takes around 3 seconds (same as LO 5.2.2.2)


Reproducible: Always

User Profile Reset: Yes

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_1) AppleWebKit/602.2.14 (KHTML, like Gecko) Version/10.0.1 Safari/602.2.14
Comment 1 Telesto 2016-11-12 19:45:28 UTC
Created attachment 128700 [details]
LLDB Backtrace with debug symbols

Created with: Version: 5.3.0.0.alpha1+
Build ID: 64a708cba9b954afe3331f63c58218eb53b3d0ce
CPU Threads: 4; OS Version: Mac OS X 10.12.1; UI Render: default; Layout Engine: new; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 2 Telesto 2016-11-12 22:35:23 UTC
(In reply to Telesto from comment #1)
> Created attachment 128700 [details]
> LLDB Backtrace with debug symbols

I have no idea whether it's useful in anyway.
Comment 3 Alex Thurgood 2016-11-14 08:43:19 UTC
Kind of rings a bell as a DUP, but will have to trawl through the bugzilla db and try and find it.
Comment 4 Telesto 2016-11-14 09:25:27 UTC
(In reply to Alex Thurgood from comment #3)
> Kind of rings a bell as a DUP, but will have to trawl through the bugzilla
> db and try and find it.

I think you're talking about bug 103252. A bug I primarily started because of a regression between 5.2.1.1 and 5.2.1.2 because the time taken to launch LO for the first time (a without profile). 
Here I'm talking about the time needed for launching an application from a (already running) Start Center. It could be caused by the same regression, because it's introduced by the same version. But it's technically a different bug, I suppose.
Comment 5 Telesto 2018-02-24 17:43:27 UTC
*** Bug 114364 has been marked as a duplicate of this bug. ***
Comment 6 Telesto 2018-02-24 17:58:35 UTC
I found this - bug 114965 comment 1 - based on the comments at bug 114364 (duped). 

Running the following command from the Terminal resolves the problem:
xattr -d com.apple.quarantine /Applications/LibreOffice.app

It resolves the lag..
Comment 7 Telesto 2018-07-17 17:44:24 UTC
Version: 6.2.0.0.alpha0+
Build ID: 8e9d43546c8e46ea635472ddf07f5c183dc13360
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2018-07-11_23:34:15
Locale: nl-NL (nl_NL.UTF-8); Calc: group threaded