Download it now!
Bug 114970 - Autofill also copies formatting - no option to preserve formatting of cells that are filled
Summary: Autofill also copies formatting - no option to preserve formatting of cells t...
Status: RESOLVED DUPLICATE of bug 82424
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: AutoFill
  Show dependency treegraph
 
Reported: 2018-01-12 09:06 UTC by Alexander Ilyin
Modified: 2020-04-27 16:57 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Ilyin 2018-01-12 09:06:35 UTC
Could you please add the Autofill mode without format changing. E.g. when user is dragging the cell bottom right handle with Alt key do not copy the source cell format.

When you are dragging the bottom right cell handle the Autofill is copying the format cell as well. Often it is needed to autofill formulas or values only and keep the cell format (background, color etc).

Also you can add toolbar button to switch Autofill modes.

Here is discussion with workaround:
https://forum.openoffice.org/en/forum/viewtopic.php?f=9&t=31609
Comment 1 Xavier Van Wijmeersch 2018-01-12 15:36:22 UTC
In newer versions from 5.3 => 6.1 alpha there is a something like paste only text, number or formula. In 6.1 there is even more options.
Try to install a still or fresh LO and you will have what you want

Best regards
Comment 2 Alexander Ilyin 2018-01-12 19:11:40 UTC
I did not find 6.1 however I have installed and tried out the dev nightly build:
libo-60-64_2018-01-12_01.38.12_LibreOfficeDev_6.0.1.0.0_Win_x64

The autofill is still screw up my formatting and no good way to deal with it.
The only workaround with paste special described in the mentioned forum. But paste is working well in 5.x and I believe in the earlier versions.

It helps but not too much because it is annoying to do autofill, see the screwed up cell formats, undo, select the cells, copy, do autofill and then select it again and do special paste with format only.

Instead it would be very useful to do autofill without cell format changes. Just values and formulas. E.g. when user holds Alt.

According to the mentioned forum post the Excel can do that if you drag handle using right-click. That is good way do as well.
Comment 3 Thomas Lendo 2018-01-16 20:47:58 UTC
Maybe an additional modifier key can help to keep the formatting of autofilled cells. How's about the Shift key in addition to autofill selection (for ascending values) and Ctrl+autofill selection (for identical values)?
Comment 4 Alexander Ilyin 2018-01-17 07:36:20 UTC
Shift key will be great!

That way you can add even more combinations.

-Shift key in addition to autofill selection (for ascending values) to keep original formating 

-Ctrl+autofill selection (for identical values)

+Shift+Ctrl+autofill - keep original formatting and for identical values
Comment 5 Heiko Tietze 2018-01-17 08:03:59 UTC
Shift/Cmd+<drag> sounds like a good solution; just don't use Alt as it is the hotkey to moves the Window under Linux.

Alternatively, keep things and use the remove formatting command (ctrl+M).
Comment 6 Cor Nouws 2018-01-17 15:36:43 UTC
indeed mind the existing Ctrl+autofill, already mentioned in comment #4
Comment 7 Markus Grob 2018-08-09 21:10:49 UTC
Could you please test, if your behaviour is fullfilled with LO 6.1.0.2?
Comment 8 Alexander Ilyin 2018-08-12 10:57:17 UTC
Does not work for me.

I have tested 6.1.0.2, 6.1.0.3 and last nightly build libreoffice-6-1~2018-08-11_09.50.14_LibreOfficeDev_6.1.1.0.0_MacOS_x86-64

All for Mac

I have tried different key combination like CMD, Shift, CMD+Shift, Alt, Alt+Shift, Ctrl etc
Neither of them allow me to keep the original cell formatting and working just like default(with no modifier keys)
Comment 9 Buovjaga 2020-04-27 16:57:04 UTC

*** This bug has been marked as a duplicate of bug 82424 ***