Bug Hunting Session
Bug 115006 - Impress: creating a new master slide based on an existing master slide is exceedingly hard
Summary: Impress: creating a new master slide based on an existing master slide is exc...
Status: RESOLVED DUPLICATE of bug 45617
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.0.2 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-14 18:27 UTC by sergio.callegari
Modified: 2018-01-14 21:13 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2018-01-14 18:27:52 UTC
Description:
When working with presentations, one typically relies on "master slides". In many cases, for the same presentation one needs many of them (e.g., e.g. one for the cover, one for the "standard slides", maybe one for the "last slide" or for some "special" slides, etc).

All these master slides typically need to have some differences but otherwise share a coordinated look. For this reason the most obvious way to create them would be to create one, then "duplicate" it and edit it to make another.

Unfortunately, LibO does not include a functionality to duplicate a "master slide".

Another option would be to create one master slide, then create another one and copy into it all the needed elements from the first one. Unfortunately, LibO does not allow copy and paste of most master slide elements.

A workaround to duplicate a master page seems to be:

- copy the document
- move the copy to the template folder
- open the original document, view the master pages
- use the slide -> slide master design to import the slide master from the copy saved in the templates folder.

However this seems a huge complication for a functionality that should be rather straightforward.

Steps to Reproduce:
See description

Actual Results:  
See description

Expected Results:
See description


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Regina Henschel 2018-01-14 21:13:12 UTC
Yes, that has been reported already in bug 45617, but is still not solved.

*** This bug has been marked as a duplicate of bug 45617 ***