Download it now!
Bug 115053 - PRINTs landscape despite configured as portrait still in Calc after fix for Writer (Mac OS)
Summary: PRINTs landscape despite configured as portrait still in Calc after fix for W...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.0.2 rc
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-16 20:07 UTC by bunkem
Modified: 2018-04-05 19:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen capture of switching between open windows (763.56 KB, video/x-m4v)
2018-01-22 18:18 UTC, bunkem
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bunkem 2018-01-16 20:07:29 UTC
Description:
Please see bug 92190.  It has all the details.  This was fixed but has ended up in the nightly again.

Nightly dev build libreoffice-6-0~2018-01-16_11.45.01_LibreOfficeDev_6.0.1.0.0_MacOS_x86-64

Steps to Reproduce:
1. Please see bug 92190
2. This is the same & was fixed and closed in 92190
3.

Actual Results:  
Portrait pages are printed landscape even when specifically set as portrait.

Expected Results:
If the pages are portrait, they should print portrait.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 6.0.1.0.0+
Build ID: 8c2361ec6815e8ab37858c347405b96cd5771b12
CPU threads: 8; OS: Mac OS X 10.11.6; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:libreoffice-6-0, Time: 2018-01-16_11:45:01
Locale: en-CA (en.UTF-8); Calc: group


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Telesto 2018-01-17 16:14:58 UTC
Strange, no repro
Version: 6.0.1.0.0+
Build ID: 8c2361ec6815e8ab37858c347405b96cd5771b12
CPU threads: 4; OS: Mac OS X 10.13.1; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:libreoffice-6-0, Time: 2018-01-16_11:45:01
Locale: en-CA (nl_US.UTF-8); Calc: group
Comment 2 bunkem 2018-01-17 16:27:06 UTC
Writer is OK now but since the recent updates, Calc is now turning portrait pages in print dialog and during print to landscape.  Export as PDF is OK.
Comment 3 Telesto 2018-01-21 10:36:19 UTC
(In reply to bunkem from comment #2)
> Writer is OK now but since the recent updates, Calc is now turning portrait
> pages in print dialog and during print to landscape.  Export as PDF is OK.

Could you please add a sample document? I couldn't repro it
Comment 4 bunkem 2018-01-22 18:17:21 UTC
I have to figure out how to create a sample document because I can't send you the any of the existing sheets due to privacy issues.  

This is what I have found today.  It should help you recreate the issue.

If you have multiple sheets in the spreadsheet and one of those sheets is to print in landscape, then when you open the print dialog the page that is portrait will be oriented landscape also.  This happens in the default print dialog box with "Selected Sheet(s) Only".  (For example I have a 68 sheet spreadsheet with every third sheet is to print landscape.  The second and third sheets are set up as portrait.)

It looks like you can fix it by selecting the tick box "Print Selection" on and off.  It reorients the page.

It also looks like it will be fixed by switching between Print Contect "All Sheets" and "Selected Sheets".

See attached screen capture
Comment 5 bunkem 2018-01-22 18:18:03 UTC
Created attachment 139267 [details]
Screen capture of switching between open windows
Comment 6 Buovjaga 2018-02-12 18:23:27 UTC
Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the document.
Comment 7 Telesto 2018-04-05 10:34:11 UTC
Before I forget. This problem might be resolved after this commit:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=8bc951daf79decbd8a599a409c6d33c5456710e0

Please test it again with a very recent nightly build (not available at this point)

https://dev-builds.libreoffice.org/daily/master/MacOSX-x86_64@49-TDF/current/
Comment 8 bunkem 2018-04-05 19:00:18 UTC
Thank you.

I've tested both 
Version: 6.1.0.0.alpha0+
Build ID: a488c7ad2763b944713997911c1ddb0315d8c93f
CPU threads: 8; OS: Mac OS X 10.11.6; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2018-03-26_00:38:29
Locale: en-US (en.UTF-8); Calc: group

and

Version: 6.0.3.2
Build ID: 8f48d515416608e3a835360314dac7e47fd0b821
CPU threads: 8; OS: Mac OS X 10.11.6; UI render: default; 
Locale: en-CA (en.UTF-8); Calc: group

Both print landscape and portrait properly within the same print job!
Comment 9 Buovjaga 2018-04-05 19:29:14 UTC
Let's set to fixed as we know the commit for once :)
Comment 10 Buovjaga 2018-04-05 19:30:48 UTC
Argh, I was wrong: it cannot be https://cgit.freedesktop.org/libreoffice/core/commit/?id=8bc951daf79decbd8a599a409c6d33c5456710e0 because it is so new it is not in 6.0.3 yet.

So back to WFM.