Download it now!
Bug 115125 - UI: Insert table with dialog Insert Table creates table border, also if "Border" is unchecked
Summary: UI: Insert table with dialog Insert Table creates table border, also if "Bord...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectNotNeeded, regression
: 115605 (view as bug list)
Depends on:
Blocks: Writer-Table-Insert-Dialog
  Show dependency treegraph
 
Reported: 2018-01-20 15:31 UTC by Cor Nouws
Modified: 2018-03-14 19:11 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2018-01-20 15:31:15 UTC
New Writer file
Ctrl+F12
uncheck Border, Enter
  > resulting table does have border

noticed in Version: 6.1.0.0.alpha0+
Build ID: f96dbc3dd9c33202f75e29ef49d962386595995d
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-01-17_22:24:15
Locale: nl-NL (nl_NL.UTF-8); Calc: group threaded

but likely to be the case from commit http://cgit.freedesktop.org/libreoffice/core/commit/?id=203b913155812706e9be14c5fe2b8f543cc4fdc7&h=libreoffice-6-0 from bug 107555.
Comment 1 Chavdar 2018-01-20 16:01:47 UTC
Confirmed

Version: 6.0.0.2 (x64)
Build ID: 06b618bb6f431d27fd2def25aa19c833e29b61cd
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: bg-BG (bg_BG); Calc: group
Comment 2 Jim Raykowski 2018-01-20 21:37:30 UTC
Hi Cor,

This also happens when a format is selected in the AutoFormat dialog and then the Border checkbox is uncheck in the Insert Table dialog. 

Here are the steps:

1. Open Writer
2. Open the Insert Table dialog Ctrl+F12
3. Click on AutoFormat button
4. Select an AutoFormat from the Format list
5. Click on OK button
6. In Insert Table dialog uncheck Border
7. Click on Insert button

Actual Result:
table is inserted with border

Expected Result:
table is inserted without border

Another long time bug revealed by the "Apply the 'Default Style' table style to newly inserted tables" enhancement...
Comment 3 Yousuf Philips (jay) (retired) 2018-01-21 09:05:17 UTC
The border checkbox in the dialog is intended to be removed as inserted tables automatically get the default table style (bug 107555), which has borders on.
Comment 4 Cor Nouws 2018-01-21 16:14:00 UTC
(In reply to Yousuf Philips (jay) from comment #3)
> The border checkbox in the dialog is intended to be removed as inserted
> tables automatically get the default table style (bug 107555), which has
> borders on.

A user friendly solution is, to apply a table style without borders when users use the checkbox.
Comment 5 Yousuf Philips (jay) (retired) 2018-01-22 10:32:28 UTC
(In reply to Cor Nouws from comment #4)
> A user friendly solution is, to apply a table style without borders when
> users use the checkbox.

We dont ship the default table style without borders, so if that is what is needed, then this new table style would need to be created, else the inserted table style would need to have borders removed through direct formatting.
Comment 6 Heiko Tietze 2018-01-22 11:18:42 UTC
I would remove the checkbox "Border" as we have the formats anyway (ideally shown as list directly in this dialog). Also just "Border" is kind of in-your-face terminology, same for Heading. HIG wise: Label functions with a Verb-Noun combination.
Comment 7 Cor Nouws 2018-01-22 11:36:47 UTC
If there is the option in the dialog to simply choose a no border option, that is fine.
Forcing users to make extra steps via Styles and Formatting doesn't seem logic.

(Side note: I think it is a change in the right direction that now a new table does have a style that is accessible in the list Styles and Formatting.
This in planned for lists too?)
Comment 8 Heiko Tietze 2018-01-23 09:00:35 UTC
@X1sco: No need to bibisect. The issue has been introduced with the new application of the default style to newly added tables (or any other style as Jim points out in comment 2). Tables were "directly formatted" before, with or without borders, and receive a style now (with border for default). 

Cor's request is to apply the style and remove the border property subsequently when the checkbox was set, whereas my position is that a dedicated style without borders have to get selected when the user wants this table design.
Comment 9 Harry Harmsen 2018-02-07 10:17:00 UTC
Although I don't quite understand the discussion above, I recognize the problem. In LO 5.4 I could uncheck in Options-LibreOffice Writer-Table the border. But in LO 6.0 that doesn't have result: tables still have borders. I would have a standard tablestyle without borders.
Comment 10 Yousuf Philips (jay) (retired) 2018-02-27 07:53:56 UTC
This issue will be fixed with Furkan's patch.

https://gerrit.libreoffice.org/#/c/49886/
Comment 11 Telesto 2018-03-14 14:37:13 UTC
Patch has been merged already.. Not sure if this should still be open...

Anyway, what's the idea with the border checkbox in Tools-> Options -> LibreOffice Writer -> Table -> New Table defaults?

Unchecking 'border' has no effect either
Comment 12 Telesto 2018-03-14 14:38:40 UTC
*** Bug 115605 has been marked as a duplicate of this bug. ***
Comment 13 Cor Nouws 2018-03-14 19:11:04 UTC
(In reply to Telesto from comment #11)
> Patch has been merged already.. Not sure if this should still be open...
> 
> Anyway, what's the idea with the border checkbox in Tools-> Options ->
> LibreOffice Writer -> Table -> New Table defaults?

I've created bug 116407 for that.