Download it now!
Bug 115131 - New UNO command that joins Toolbar Layout submenu and Notebookbar submenu
Summary: New UNO command that joins Toolbar Layout submenu and Notebookbar submenu
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Kshitij
URL:
Whiteboard: target:6.1.0
Keywords:
: 106470 (view as bug list)
Depends on: 117124
Blocks: UNO-Command-New Notebookbar
  Show dependency treegraph
 
Reported: 2018-01-21 04:41 UTC by baffclan
Modified: 2018-08-01 09:38 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (85.08 KB, image/jpeg)
2018-01-21 04:43 UTC, baffclan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description baffclan 2018-01-21 04:41:14 UTC
Description:



Steps to Reproduce:
1. Start LibreOffice
2. Create New Witer Document
3. Change to Tabbed/Notebookbar
   Menu - View - Toolbar Layout - Notebookbar
   Menu - Notebookbar - Tabbed(or others)


Actual Results:  

3. Change to Tabbed/Notebookbar
   Menu - View - Toolbar Layout - Notebookbar
   Menu - Notebookbar - Tabbed(or others)


Expected Results:

3. Change to Tabbed/Notebookbar
   Menu - View - Toolbar Layout - Notebookbar - Tabbed(or others)



Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.0.0.2 (x64)
Build ID: 06b618bb6f431d27fd2def25aa19c833e29b61cd
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: ja-JP (ja_JP); Calc: group

Version: 6.1.0.0.alpha0+ (x64)
Build ID: facfc2951ea9f4745edd4a6fb1cf97697f33f40a
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2018-01-14_00:42:04
Locale: ja-JP (ja_JP); Calc: group threaded



User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 baffclan 2018-01-21 04:43:09 UTC
Created attachment 139237 [details]
Screenshot

Screenshot
Comment 2 Yousuf Philips (jay) (retired) 2018-01-28 13:54:36 UTC
A new UNO command needs to be created to merge the Toolbar Layout submenu (.uno:ToolbarMode) and the Notebookbar submenu (.uno:Notebookbar). The new submenu would first list the Toolbar Layout submenu entries followed by a separator and then the Notebookbar submenu entries.
Comment 3 Kshitij 2018-02-11 20:59:29 UTC
Hi!I would like to work on this work .
Comment 4 Kshitij 2018-02-11 22:22:23 UTC
I have submitted the patch https://gerrit.libreoffice.org/#/c/49575/ .
I have tried to follow the instruction in comment #2.
To make it similar to screenshot ,it seems like it can be done without changing uno command,for that changing the files libreoffice/officecfg/registry/data/org/openoffice/Office/UI/ToolbarMode.xcu and /ToolbarMode.xcs of .uno:ToolbarMode
will work .
Comment 5 Yousuf Philips (jay) (retired) 2018-02-14 20:08:53 UTC
(In reply to Kshitij from comment #4)
> I have submitted the patch https://gerrit.libreoffice.org/#/c/49575/ .

Saw the patch and thats definitely not what is needed by adding the two submenus into a submenu in the menu, as i could have easily done that.

> I have tried to follow the instruction in comment #2.

Yes this is what is needed a list like this

Toolbar Layouts
  Standard
  Single
  Sidebar
  - separator -
  Notebookbar > Contextual groups
  Notebookbar > Contextual single
  ...

> To make it similar to screenshot ,it seems like it can be done without
> changing uno command,for that changing the files
> libreoffice/officecfg/registry/data/org/openoffice/Office/UI/ToolbarMode.xcu
> and /ToolbarMode.xcs of .uno:ToolbarMode
> will work .

The mockup in comment 1 shouldnt be followed as you shouldnt have to open up a submenu for the notebookbar entries.

Maxim: got some code pointers to help Kshitij do this.
Comment 6 Maxim Monastirsky 2018-02-18 09:48:07 UTC
(In reply to Yousuf Philips (jay) (retired) from comment #2)
> A new UNO command needs to be created to merge the Toolbar Layout submenu
> (.uno:ToolbarMode) and the Notebookbar submenu (.uno:Notebookbar).
I would assume that the separate sub menus won't be needed after we have the merged menu, so it would be better to just enhance the existing .uno:ToolbarMode, and then remove .uno:Notebookbar and all of its code.

(In reply to Yousuf Philips (jay) (retired) from comment #5)
> Maxim: got some code pointers to help Kshitij do this.

The code for the .uno:ToolbarMode menu is in framework/source/uielement/toolbarmodemenucontroller.cxx, and its items are handled by the application code in sfx2/ as SID_TOOLBAR_MODE.

The code for .uno:Notebookbar menu is in framework/source/uielement/notebookbarmenucontroller.cxx, and the corresponding id in the application code is SID_NOTEBOOKBAR.
Comment 7 Yousuf Philips (jay) (retired) 2018-02-18 17:10:31 UTC
(In reply to Maxim Monastirsky from comment #6)
> I would assume that the separate sub menus won't be needed after we have the
> merged menu, so it would be better to just enhance the existing
> .uno:ToolbarMode, and then remove .uno:Notebookbar and all of its code.

I believe there will be situations when these two separate submenus would be utilized, which is why i'm suggesting a new uno command be created with the merging of the two submenus.
Comment 8 Commit Notification 2018-04-02 07:28:13 UTC
Kshitij Pathania committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5c573a2f7473bae7bb965ca36557cd1b0bf7b9c9

tdf#115131 made a common submenu for toolbars and notebookbars

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2018-05-03 10:11:10 UTC
A polite ping to Kshitij Pathania: is this bug fixed? if so, could you
please close it as RESOLVED FIXED ? Thanks
Comment 10 V Stuart Foote 2018-05-06 20:58:34 UTC
*** Bug 106470 has been marked as a duplicate of this bug. ***