Bug 115228 - TSCP / classification terminology in UI: need improvement
Summary: TSCP / classification terminology in UI: need improvement
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.0.2 rc
Hardware: All All
: medium enhancement
Assignee: Cor Nouws
URL:
Whiteboard: target:6.1.0 target:6.3.0
Keywords:
: 114668 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-01-25 12:33 UTC by Olivier Hallot
Modified: 2019-01-14 09:03 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Hallot 2018-01-25 12:33:48 UTC
Description:
I'd like to suggest changes in the TSCP classification dialogs in the UI

in the Classification toolbar:

"Classification Dialog" -> Classification
"Paragraph Classification Dialog" -> Paragraph Classification"


Classification Dialog title: "Contents Classification"


Steps to Reproduce:
To open the dialogs:
1) Enable classification toolbar (View - Toolbar - Classification)
2) click on one of the buttons.


Actual Results:  
Bad wording

On some languages the noun Classification may be changes to the verb "Classify"

Expected Results:
Better wording


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Cor Nouws 2018-01-25 13:04:30 UTC
I support the change of labels on the buttons on the tool bar to  "Advanced Classification" and  "Advanced Paragraph Classification".

The label for the drop down on the left has to be looked at too. "Intellectual Property" might as well be security, privacy..
Could be "Classification" or "Simple Classification". Will discuss that with others. (And also check the origin of the label - possibly it comes from the .xml file, and thus is flexible by design).
Comment 2 Heiko Tietze 2018-01-27 10:16:44 UTC
Patch at https://gerrit.libreoffice.org/#/c/48744/

Intellectual property: -> Secrecy level

Classification Dialog -> Manage document classification
Paragraph Classification Dialog -> Manage paragraph classification
Apply Document Classification -> Apply document classification

Classification Dialog -> Classification


I've spotted some mistakenly title style formatted captions recently. Upper case is applied to dialog captions only, not commands, ordinary menu items, or UI labels. 

Also, do not use colons to identify the relation between caption and control (like above for IP).
Comment 3 Heiko Tietze 2018-01-29 08:34:37 UTC
(In reply to Heiko Tietze from comment #2)
> Patch at https://gerrit.libreoffice.org/#/c/48744/
> 
> Intellectual property: -> Secrecy level

Intellectual property: -> Level
Comment 4 Commit Notification 2018-03-18 09:08:22 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5620d620dce3eecc1eaa6b9062e210fb57bf59ea

tdf#115228 Terminology TSCP

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Stanislav Horacek 2018-03-24 12:00:43 UTC
*** Bug 114668 has been marked as a duplicate of this bug. ***
Comment 6 Cor Nouws 2019-01-08 16:44:01 UTC
(In reply to Commit Notification from comment #4)
> heiko tietze committed a patch related to this issue.
> It has been pushed to "master":
> 
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=5620d620dce3eecc1eaa6b9062e210fb57bf59ea

Noticing the following: as far as I see, nouns in our UI always start with an uppercase.
So in this case it should be "Manage Document Classification" and "Manage Paragraph Classification" ?
Comment 7 Heiko Tietze 2019-01-08 16:56:29 UTC
(In reply to Cor Nouws from comment #6)
> Noticing the following: as far as I see, nouns in our UI always start with
> an uppercase.

In the menu, yes, but tooltips are sentence style. Anyway, this needs improvement. Kompi, are you interested?
Comment 8 Cor Nouws 2019-01-08 22:13:25 UTC
(In reply to Heiko Tietze from comment #7)
> (In reply to Cor Nouws from comment #6)
> > Noticing the following: as far as I see, nouns in our UI always start with
> > an uppercase.
> 
> In the menu, yes, but tooltips are sentence style. Anyway, this needs
> improvement. Kompi, are you interested?

Have some more easy things around classification - will take this one if you don't mind
Comment 9 Cor Nouws 2019-01-11 13:58:22 UTC
(In reply to Cor Nouws from comment #8)

> Have some more easy things around classification - will take this one if you
> don't mind
patch  https://gerrit.libreoffice.org/66175
Comment 10 Commit Notification 2019-01-11 16:16:02 UTC
Cor Nouws committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/46f2c64eee2213e2921f28645c4ba907d6b83885%5E%21

tdf#115228 nouns in UI are uppercase, hence Manage Document Classification and ..

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Heiko Tietze 2019-01-14 08:01:49 UTC
Patch makes sense, but cant you close the ticket now again?