Bug Hunting Session
Bug 115265 - Enhancement to Middle mouse button panning
Summary: Enhancement to Middle mouse button panning
Status: RESOLVED DUPLICATE of bug 66410
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.4.4.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-27 23:41 UTC by divers
Modified: 2018-02-15 20:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description divers 2018-01-27 23:41:40 UTC
Description:
This is an enhancement request for Draw.
Panning is a basic documentation browsing function.
To me, it as important as scrolling and zooming.

Those two functions (scrolling and zooming) do not require to select a dedicated tool in order to work. With the Select tool active, as soon as the mouse cursor is in the viewing area of the document, they just plain work: the [scroll wheel] scrolls the document, and Ctrl+[scroll wheel] will zoom in/out.

However, the same cannot be said of the panning function.
To be able to pan, the "Zoom & Pan" tool needs to be active and one will then use Shift+[middle mouse button].

It would be much better to be able to pan just using the [middle mouse button] on its own (or possibly along with the Shift key) when the cursor is in the document viewing area, in Select mode.
Various other programs work this way I believe.

Steps to Reproduce:
Activate the Select tool.
Try to pan using the middle mouse button.

Actual Results:  
Panning does not work.

Expected Results:
Panning works.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
See Description.


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 Buovjaga 2018-02-15 20:24:30 UTC

*** This bug has been marked as a duplicate of bug 66410 ***