Bug Hunting Session
Bug 115303 - FILESAVE CALC Freeze Cells fails when window frame abuts frozen pane
Summary: FILESAVE CALC Freeze Cells fails when window frame abuts frozen pane
Status: RESOLVED DUPLICATE of bug 112641
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.1.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Cell-Freeze
  Show dependency treegraph
 
Reported: 2018-01-29 21:04 UTC by duncantho
Modified: 2018-04-03 23:25 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description duncantho 2018-01-29 21:04:02 UTC
Saving after setting 'Freeze Rows and Columns' works only so long as the bottom edge of the window is clear of the row immediately below the frozen pane. Rows become unfrozen if the bottom of window encroaches into the row next to the frozen pane at time of saving. Further, if at any time the bottom or right window frames are dragged into the frozen pane they immediately unfreeze the rows or columns, respectively. This occurs in xlsx and ods formats, in 5.4.1.2 and 5.3.0.3 releases (haven't tried other releases), running under MacOS 10.12.6.
Comment 1 Alex Thurgood 2018-01-31 08:13:30 UTC
@Duncan : 

Can you provide us with a test document with which to test ?

Does it depend on the number of rows of data in the sheet, or any other objects included ?
Comment 2 Alex Thurgood 2018-01-31 08:16:27 UTC
@Duncan OK, don't bother with the file, I can reproduce this one easily with

Version: 6.1.0.0.alpha0+
Build ID: 0f28c8612f4269cec95688b53d182c7c0169236d
CPU threads: 4; OS: Mac OS X 10.13.3; UI render: default; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group threaded
Comment 3 duncantho 2018-02-01 05:12:42 UTC
Alex, apologies for my slow response. Glad you were able to duplicate the problem in the absence of a file from me. Good luck with a fix.
Comment 4 Holger Klene 2018-04-03 23:25:11 UTC

*** This bug has been marked as a duplicate of bug 112641 ***