Bug Hunting Session
Bug 115312 - [NEWHELP] Make NewHelp makefiles build only right XHP files
Summary: [NEWHELP] Make NewHelp makefiles build only right XHP files
Status: RESOLVED DUPLICATE of bug 116240
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: New-Help
  Show dependency treegraph
 
Reported: 2018-01-30 13:17 UTC by Olivier Hallot
Modified: 2018-06-13 19:20 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Hallot 2018-01-30 13:17:34 UTC
Description:
Current implementation of new help Makefiles

helpcontent2/CustomTarget_html.mk

applies the XSLT transformation to all xhp files (*.xhp). 

However, many xhp files are not a Help page per se but often source of embed for other help pages.

The actual help pages to be processed are described in these makefiles:

AllLangHelp_sbasic.mk
AllLangHelp_scalc.mk
AllLangHelp_schart.mk
AllLangHelp_sdatabase.mk
AllLangHelp_sdraw.mk
AllLangHelp_shared.mk
AllLangHelp_simpress.mk
AllLangHelp_smath.mk
AllLangHelp_swriter.mk

Therefore, CustomTarget_html.mk should use the makefiles above instead of *.xhp with reduction of the processing time and also to trigger a rebuild on change of the xhp's listed in the AllLangHelp_*.mk files.


Steps to Reproduce:
1. make CustomTarget_hmtl

Actual Results:  
a set oh html help pages bigger than needed...

Expected Results:
set of html help page actually needed.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Olivier Hallot 2018-06-13 19:20:50 UTC
Closing: bug 116240 address and solve this issue.

*** This bug has been marked as a duplicate of bug 116240 ***