Bug Hunting Session
Bug 115330 - Navigation with Find Toolbar does not work Correctly with Bookmarks
Summary: Navigation with Find Toolbar does not work Correctly with Bookmarks
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Bookmarks Find-Toolbar Navigate-By
  Show dependency treegraph
 
Reported: 2018-01-31 12:19 UTC by Harald Koester
Modified: 2018-10-25 12:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2018-01-31 12:19:50 UTC
In order to reproduce the bug do:

[1] Open new text document.
[2] Insert some text.
[3] Insert 2 bookmarks somewhere in the text. 
[4] Display find toolbar and select 'Bookmarks' in 'Navigate By' drop down menu.
[5] Click in front of the first character in or to position the cursor.
[5] Click down arrow (previous bookmark) three times. The cursor jumps to the position of the two bookmarks and then to the end of the document. It seems that there is a bookmark at the end of the document, but it is not. Expected: No jump to the end of the document but a message, that there is no more bookmark. 

The other way round the same problem exists: If you click the up arrow (previous bookmark) several times the cursor jumps to the beginning of the document and it seemed that there is a bookmark at the beginning of the document.
Comment 1 Dieter Praas 2018-01-31 12:33:31 UTC
I confirm it with

Version: 6.1.0.0.alpha0+ (x64)
Build ID: 77a535285f0fd5f2464430abdc67cf99be024868
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-01-23_23:04:23
Locale: de-DE (de_DE); Calc: CL
Comment 2 Jim Raykowski 2018-03-24 02:16:19 UTC
I also comfirm this. 

Maybe the navigation should wrap to the next available bookmark and 'Navigation wrapped' or something of the sort could be displayed in the findbar message area. 

Bug 115600 may be a better place for futher discussion of this proposal for navigation behavior change.
Comment 3 Harald Koester 2018-10-25 12:24:48 UTC
Checked with 
- version 6.0.6: Bug still exists
- version 6.1.0 and 6.1.2: Works for me now.