Bug 115600 - Missing Messages at the Use of “Navigate by” Function when Document Beginning or End is Reached
Summary: Missing Messages at the Use of “Navigate by” Function when Document Beginning...
Status: REOPENED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: Jim Raykowski
URL:
Whiteboard: target:6.1.0 target:6.2.0 target:6.3.0
Keywords:
Depends on:
Blocks: Find-Toolbar
  Show dependency treegraph
 
Reported: 2018-02-09 22:51 UTC by Harald Koester
Modified: 2019-04-18 02:12 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2018-02-09 22:51:12 UTC
In order to reproduce do:

[1] Create a new text document with some headings.
[2] Display Find toolbar.
[3] In this toolbar select “Headings” in “Navigate By” drop down menu.
[4] Use the arrow buttons several times in order to navigate to the next or previous heading. If you reach the first or last heading and then click the arrow button again nothing happens. Expected: Messages that inform the user that the beginning or end of the document is reached like they are displayed if you use the find function in the same toolbar. 

Of course messages should not only used with headings but with all object types (Table, Drawing, Control,...).
Comment 1 IWAMOTO 2018-02-19 06:57:54 UTC
Did not reproduce in the following environment.

Version: 6.0.1.1 (x64)
Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
Locale: ja-JP (ja_JP); 
OS:Winsows7 Home Premium x64
Comment 2 Dieter Praas 2018-02-19 08:03:15 UTC
Reproducible for me with

Version: 6.1.0.0.alpha0+ (x64)
Build ID: 77a535285f0fd5f2464430abdc67cf99be024868
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-01-23_23:04:23
Locale: de-DE (de_DE); Calc: CL
Comment 3 Mohamed 2018-02-20 02:15:52 UTC
Issue is reproduced.

Operating system : Windows 8.1 Pro 64-bits.
Version: 6.0.0.3 (x64)
Build ID: 64a0f66915f38c6217de274f0aa8e15618924765
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: en-US (en_US); Calc: group
Comment 4 IWAMOTO 2018-02-20 05:31:04 UTC
(In reply to IWAMOTO from comment #1)
> Did not reproduce in the following environment.
> 
> Version: 6.0.1.1 (x64)
> Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
> Locale: ja-JP (ja_JP); 
> OS:Winsows7 Home Premium x64


Sorry,I tried the test again and the issue is reproducing.
Comment 5 Xisco Faulí 2018-02-23 13:15:28 UTC
Also reproduced in

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

@Jim, one for you ?
Comment 6 Jim Raykowski 2018-03-14 03:40:15 UTC
(In reply to Xisco Faulí from comment #5)
> Also reproduced in
> 
> Version: 4.3.0.0.alpha1+
> Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
> 
> @Jim, one for you ?

Hi Xisco,

There are many Navigate By elements so if others want to participate...

I will start with Headings if that is ok?
Comment 7 Xisco Faulí 2018-03-14 08:13:44 UTC
(In reply to Jim Raykowski from comment #6)
> (In reply to Xisco Faulí from comment #5)
> > Also reproduced in
> > 
> > Version: 4.3.0.0.alpha1+
> > Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
> > 
> > @Jim, one for you ?
> 
> Hi Xisco,
> 
> There are many Navigate By elements so if others want to participate...
> 
> I will start with Headings if that is ok?

Absolutely!! It was just a suggestion. I didn't mean you have to do it.
Regards
Comment 8 Jim Raykowski 2018-03-22 07:33:02 UTC
Hi All,

Currently navigation wrapping behaviors are as follows:

Does not wrap:
Table, Page, Heading, Section, Bookmark[1], Footnote, Comment, Index entry, Table formula, Wrong table formula[2]

Wraps:
Text Frame, Graphics, OLE object, Reminder, Drawing, Control, Selection

IMHO :) all should wrap and the message displayed in the findbar '[placeholder for message]' area could be 'Navigation wrapped' when wrapping occurs. 

If anyone else thinks this sounds good we should make a separate change of behavior request for it.    

I have a patch ready that changes Headings to wrap and another patch ready for 'Navigation wrapped' in the findbar.

------------------------------
[1] navigates past first and last to beginning and end of document
[2] assumption as I wasn't successful in testing
Comment 9 Jim Raykowski 2018-03-29 22:54:15 UTC
(In reply to Jim Raykowski from comment #8)

Here is a patch that provides messages for Heading navigation and changes the current navigation behavior from not wrapping to wrapping.

https://gerrit.libreoffice.org/#/c/52139/
Comment 10 Commit Notification 2018-04-09 05:47:53 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0b859bf33ed722c5c90f41cb08099fecfe494272

tdf#115600 Display messages in Findbar for Headings navigation

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Jim Raykowski 2018-04-09 06:13:40 UTC
I see this has been set to Resolved Fixed but there are many more Navigate By elements to provide messages that inform the user that the beginning or end of the document is reached. As of yet only a patch for Headings has been made.
Comment 12 Samuel Mehrbrodt (CIB) 2018-04-09 06:22:13 UTC
(In reply to Jim Raykowski from comment #11)
> I see this has been set to Resolved Fixed but there are many more Navigate
> By elements to provide messages that inform the user that the beginning or
> end of the document is reached. As of yet only a patch for Headings has been
> made.

Ah, sorry, didn't see that. So are you planning to work on the other types? Then please set to ASSIGNED.
Setting this to NEW for now.
Comment 13 Jim Raykowski 2018-04-09 07:15:01 UTC
 
> Ah, sorry, didn't see that. So are you planning to work on the other types?
> Then please set to ASSIGNED.

There are many of these so I thought maybe it would be good to let others contribute if they would like but if you think it would be best for me to assign to myself I will do that.
Comment 14 Jim Raykowski 2018-04-14 06:16:55 UTC
Here is a patch that provides messages for Table navigation and adds wrapping.

https://gerrit.libreoffice.org/#/c/52865/
Comment 15 Commit Notification 2018-04-14 18:36:18 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f7d155e71dec5024f2d06dcf3697d1dcf505716a

tdf#115600 Display messages in Findbar for Table navigation

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2018-04-17 06:28:21 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cc3690c9694e79d913c370ef1983c83f38dae23a

tdf#115600 Display messages in Findbar for Text Frame, Graphics, OLE

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2018-04-26 14:16:32 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3659520e3324779b6bf7c0f5a5b3f3072e8a875a

tdf#115600 Display messages in FindBar for Bookmark navigation

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2018-04-26 14:16:39 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7a30e0d63d37eeb7b5c1e30791de17a51ddd0652

tdf#115600 Display messages in FindBar for Section navigation

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Jim Raykowski 2018-05-10 22:01:10 UTC
I have assigned this one to myself because I am working on a different approach for displaying these messages that combines the display work into one local function for use in the move navigation handler.
Comment 20 Jim Raykowski 2018-05-16 07:48:52 UTC
(In reply to Jim Raykowski from comment #19)
> I have assigned this one to myself because I am working on a different
> approach for displaying these messages that combines the display work into
> one local function for use in the move navigation handler.

I thought maybe the bool returned from a move along with document page number and PaM node and content index and/or document cursor position before and after a move could be used to decide which message to display. This approach didn't pan out :( but no worries, I've gained a bit more knowledge of the document model and PaM workings. So continuing with the separate patches approach.
Comment 21 Jim Raykowski 2018-05-18 21:30:58 UTC
This patch adds messages and wraps Footnote navigation:

https://gerrit.libreoffice.org/#/c/54556/
Comment 22 Commit Notification 2018-05-21 13:49:15 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b3b169ddd99be71afe0da19afefcb9a6173a2e79

tdf#115600 Display messages in FindBar for Footnote navigation

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 23 Jim Raykowski 2018-06-04 22:34:49 UTC
Hi All, 

Here are a couple more of these that are ready for review.

Reminder:
https://gerrit.libreoffice.org/#/c/55240/

Comment:
https://gerrit.libreoffice.org/#/c/55304/
Comment 24 Commit Notification 2018-06-05 18:52:06 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c25b63b430595e6470284644bf2f2197b3e8eed7

tdf#115600 Display messages in FindBar for Reminder navigation

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 25 Jim Raykowski 2018-06-06 07:29:07 UTC
Here for review is what maybe the last of these :) 
https://gerrit.libreoffice.org/#/c/55358/

This patch is for both Table formula and Wrong table formula navigation.
Comment 26 Jim Raykowski 2018-06-06 08:17:36 UTC
The only items that do not have messages are Selection and Page.

Since selection navigation is done by order of selection, "Reached end/beginnig of document, continued from beginning/end" don't always make sense. "Navigation element not found" may be nice for consistency.

Adding messages and wrapping for Page navigation is doable, should it be done?

Thoughts are welcome :)
Comment 27 Commit Notification 2018-06-13 07:50:45 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f056cb7cec76b0769703176a27ac298461ff411a

tdf#115600 Display messages in FindBar for Comment navigation

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 28 Commit Notification 2018-06-13 07:56:42 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dbe3f1c451cf834926d0ddf03c29bcbbea87e49c

tdf#115600 Display messages in Findbar for Table formula navigation

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 29 Jim Raykowski 2018-06-21 20:54:01 UTC
Since this is finished I would like to add mention of it to the Release Notes but am unsure which release notes to add to. Most of these will be available in 6.1.0 with some not available until 6.2.0.
Comment 30 BogdanB 2018-10-22 13:44:26 UTC
Verified. Fixed.

Tested on:
Version: 6.2.0.0.alpha0+
Build ID: 3846561f79cf9065abd9ca83c9fbfbe7e52e28e2
CPU threads: 4; OS: Linux 4.15; UI render: GL; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-10-21_02:45:54
Locale: en-US (ro_RO.UTF-8); Calc: threaded
Comment 31 Harald Koester 2019-04-10 11:08:12 UTC
I tested the behaviour (version 6.2.2, 64 bit, Win10) with all items of the "Navigate By" drop down menu. With most of the items the function works correctly. But there are still some problems:

[1] Item "Page": No message if the beginning or end of the document is reached. No wrap.
[2] Item "Control": Only works if the Design Mode is activated.
[3] Item "Selection": No message if the end or beginning is reached.
[4] Item "Selection": No message if a Navigation Element does not exist.
[5] Item "Repeat Search": Message is different if the end is reached.
[6] Item "Repeat Search": No message if the beginning is reached.
Comment 32 Jim Raykowski 2019-04-12 07:52:31 UTC
(In reply to Harald Koester from comment #31)

[1] Patch to add Navigate By page wrapping is here:
https://gerrit.libreoffice.org/#/c/70640/

[2] Design mode needs to be on for Navigate By Control to work so here is a patch that toggles it on if off, when Previous or Next control button is pressed:
https://gerrit.libreoffice.org/#/c/70644/

[3][4] Selection navigation is in the order selections are made. The next selection position may be before or after the current selection position in the document. This can be seen by making multiple selections starting from the end of a document and adding each new selection above the previous then use the Navigate By Next selection button which will move up the document somewhat opposite as expected. There doesn't seem an easy way to add indication of first selection to tell if wrapping has occurred. Here is a patch to show the 'Navigation Element not found' message when there is no selection:
https://gerrit.libreoffice.org/#/c/70645/

[5][6] Repeat Search only works after a find text search is made. The wrapping messages displayed when find text wraps are different than when Navigate By wraps. Find text wrapping displays 'Reached the beginning of the document' or 'Reached the end of the document'. Navigate By wrapping displays 'Reached the end of the document, continued from the beginning' or 'Reached the beginning of the document continued from the end' except for the Navigate By Repeat Search which uses the find text wrapping messages.
Comment 33 Commit Notification 2019-04-15 02:09:43 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/b4869c08b81a1bc707c882a1b3668b056e8f44d1%5E%21

tdf#115600 Display messages in Findbar for Navigate By Page

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 34 Commit Notification 2019-04-17 02:38:44 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/f91603a983d4e109983d4f976786ac794e63e547%5E%21

tdf#115600 Turn design mode on to Navigate by Control

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 35 Commit Notification 2019-04-18 02:12:41 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/aebf19251cef417b387c7830535542ff11d54cea%5E%21

tdf#115600 Display not found message for Navigate by Selection

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.