Bug 115344 - FORMATTING - Format -> Columns... dialog missing
Summary: FORMATTING - Format -> Columns... dialog missing
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: All All
: medium normal
Assignee: Cor Nouws
URL:
Whiteboard: target:6.1.0
Keywords:
: 115760 118642 (view as bug list)
Depends on:
Blocks: Writer-Menus Page-Layout-Columns
  Show dependency treegraph
 
Reported: 2018-01-31 18:50 UTC by Kyle White
Modified: 2018-07-11 07:06 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Screent shot Writer 5.4.4 - Format menu (96.66 KB, image/jpeg)
2018-01-31 18:50 UTC, Kyle White
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle White 2018-01-31 18:50:05 UTC
Created attachment 139472 [details]
Screent shot Writer 5.4.4 - Format menu

Unable to insert/create text columns (not table columns) within the document.

Menu Item - "Format -> Columns..." missing.
Comment 1 Dieter Praas 2018-01-31 20:28:53 UTC
I confirm it with

Version: 6.1.0.0.alpha0+ (x64)
Build ID: 77a535285f0fd5f2464430abdc67cf99be024868
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-01-23_23:04:23
Locale: de-DE (de_DE); Calc: CL

You can add "columns" to the menu (Tools => Customize) but I think the column-option sshould be there by default.

But perhaps there was a good reason to remove it by default?
Comment 2 Yousuf Philips (jay) (retired) 2018-01-31 21:36:11 UTC
Was intentionally moved, as the column tab is available in the page and section dialogs.

https://gerrit.libreoffice.org/#/c/39017/
Comment 3 Kyle White 2018-01-31 23:28:26 UTC
The functionality of 'Columns' the the Page dialog and in the 'Sections' dialog is totally different from the missing 'Format -> Columns...' dialog.

In the original 'Format -> Columns...' dialog is is possible to convert a pre-selected section of text into columns with one dialog box.

The Page dialog affects the entire document, and the Sections dialog gives you empty columns which you then populate.  In neither case can you pre-select a section of text in the document and convert it directly into columns without affecting anything else.

Please re-visit but 115344

Thank you!

Kyle
Comment 4 Dieter Praas 2018-02-01 08:38:51 UTC
I agree to 50%

- Page dialog is not the same
- It's possible for me to select a section of text and convert it into columns with the section dialog.

So for me a kind of workaround exists. But I'm afraid that at least 80% of the normal users are not aware of this possibility (for me it was absolutely new). And at least half of them don't know about the possibility of customizing the menu.

So for me the decision to remove it is not userfriendly and I hope that the design team will rethink it.
Comment 5 Yousuf Philips (jay) (retired) 2018-02-01 18:45:26 UTC
(In reply to Kyle White from comment #3)
> The Page dialog affects the entire document, and the Sections dialog gives
> you empty columns which you then populate.  In neither case can you
> pre-select a section of text in the document and convert it directly into
> columns without affecting anything else.

You can do so with these steps
1. pre-select your text
2. Insert > Section
3. Click Columns tab and set the column details

or like so
1. pre-select your text
2. enabled the View > Toolbars > Insert toolbar
3. Click the down area button of the Section split button and set the number of columns

this Section split button can be added to one of the visible toolbars if you use this feature alot.

(In reply to Dieter Praas from comment #4)
> So for me a kind of workaround exists. But I'm afraid that at least 80% of
> the normal users are not aware of this possibility (for me it was absolutely
> new).

This isnt a workaround, this is a different workflow and it also educates users on what they are adding to their document and having a central location for when they are modifying columns of a particular type. The entry was also removed as it was a redundancy and as the Format menu was overcrowded.

> And at least half of them don't know about the possibility of
> customizing the menu.

We cant please everyone with the defaults we set, but we try to make it as good as possible for most users, and if users dont like it, they are able to modify it to their liking, and customization is normally limited to advanced users who like things in a particular way.

> So for me the decision to remove it is not userfriendly and I hope that the
> design team will rethink it.

Heiko, Stuart, Cor, Regina: what is your take on this?
Comment 6 V Stuart Foote 2018-02-01 19:28:21 UTC
(In reply to Yousuf Philips (jay) from comment #5)
> 
> Heiko, Stuart, Cor, Regina: what is your take on this?

No objection to having removed it from the Format -> Columns menu. As noted in the commit (comment 2), the Format action was converting the selected text to a section anyhow.

Otherwise there are multiple ways to handle workflow of multi-column with a text/object selection made:

  Insert -> Section

or (more useful to my use cased)

  Insert -> Frame (Interactive or Dialog) 

or
  
  Setting the Page format (against whole document)

And of course to handle consistently applying styles: modifying default Page or Frame styles and saving to Template--then work in a document created from the template and--apply the needed style(s).

In short the Format -> Columns was redundant direct formatting that interfered with well structured documents. No qualms with pruning it out.

=> NAB
Comment 7 Kyle White 2018-02-01 20:14:07 UTC
Thank you All!

Your time and efforts are much appreciated!

Kyle White
Comment 8 V Stuart Foote 2018-02-01 20:23:46 UTC
Well, as OP is convinced; unless there is further discussion needed...

 => NAB
Comment 9 Cor Nouws 2018-02-02 17:07:44 UTC
Yes!
We already have the extremely user unfriendly inserting of page numbers .. Insert > Page number.. Huh ?
Now we added another user unfriendly action.
Comment 10 Dieter Praas 2018-02-16 15:18:45 UTC
*** Bug 115760 has been marked as a duplicate of this bug. ***
Comment 11 ambimom 2018-02-16 16:24:54 UTC
All previous versions of LibreOffice allow selection of a portion of text to format into columns.  Now, the only option is to format the entire page into columns.  Extremely annoying. I presume this was an oversight.
Comment 12 V Stuart Foote 2018-02-16 16:54:48 UTC
(In reply to ambimom from comment #11)
> All previous versions of LibreOffice allow selection of a portion of text to
> format into columns.  Now, the only option is to format the entire page into
> columns.  Extremely annoying. I presume this was an oversight.

No oversight see comment 5, comment 6.

The dialog tool you seek for you work flow remains but is now manipulated from the Insert -> Section: Columns tab.

The structure of ODF and the document canvas have always used "Sections" not columns--by default a section of 1 column.
Comment 13 Cor Nouws 2018-04-20 15:15:14 UTC
Notably LibreOffice online shows the way: to help users, version 3.2 introduced Format > Columns.
Let's do the same. I submitted a patch.
Comment 14 Dieter Praas 2018-04-20 15:41:03 UTC
(In reply to Cor Nouws from comment #13)
> Notably LibreOffice online shows the way: to help users, version 3.2
> introduced Format > Columns.
> Let's do the same. I submitted a patch.

Thank you! Very userfriendly!
Comment 15 V Stuart Foote 2018-04-20 15:59:51 UTC
https://gerrit.libreoffice.org/#/c/53217/

Cor, Have to say, still don't see much need for this as it is correctly handled in Insert / Format of Sections that this is a subset of. 

But if you go ahead, you would also need to fix the Help entries.
Comment 16 Cor Nouws 2018-04-20 16:38:56 UTC
(In reply to V Stuart Foote from comment #15)

> But if you go ahead, you would also need to fix the Help entries.

Sure - thanks for the support & the hint ;)
Comment 17 Yousuf Philips (jay) (retired) 2018-04-23 07:21:16 UTC
(In reply to Cor Nouws from comment #13)
> Notably LibreOffice online shows the way: to help users, version 3.2
> introduced Format > Columns.
> Let's do the same. I submitted a patch.

LOOL copies the menu structure available in LibreOffice, so not sure why we'd copy whatever changes they make to the menus, when they have a limited subset of the menu items.
Comment 18 Cor Nouws 2018-04-24 18:49:53 UTC
(In reply to Yousuf Philips (jay) (retired) from comment #17)

> LOOL copies the menu structure available in LibreOffice, so not sure why
> we'd copy whatever changes they make to the menus, when they have a limited
> subset of the menu items.

The people working on LOOL deliberately re-added the menu item to serve customers. Why oh why should they have done so..
Comment 19 Commit Notification 2018-04-26 10:36:17 UTC
Cor Nouws committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6440f3cd504a0aa1f9522a4be60dc382cf9eef52

tdf#115344 - bring back Format > Columns in Writer

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Adolfo Jayme 2018-04-27 05:57:01 UTC
While I understand the reasoning behind this menu item’s removal and totally agree with it, honestly I’m glad it’s back, because I always had a hard time finding the columns feature in a quick manner =)
Comment 21 Cor Nouws 2018-04-28 20:32:39 UTC
(In reply to Adolfo Jayme from comment #20)
> While I understand the reasoning behind this menu item’s removal and totally
> agree with it, honestly I’m glad it’s back, because I always had a hard time
> finding the columns feature in a quick manner =)

Thanks for your honest comment :)
Comment 22 Kyle White 2018-04-29 13:23:18 UTC
I wish to take this point in time to thank everyone involved in the process of investigating and discussing the pros/cons of this item.

It has been totally fascinating watching the process that has taken place.  This is the first time I have ever followed the entire process of the changing of a feature.

Having followed the progression from StarOffice 3 on OS/2, to the current edition of LibreOffice on MacOS X, I now have a much better grasp of the level of dedication and commitment the developers have for this project.

Once again, Thank You, all, very much!

Kyle White
Comment 23 Thomas Lendo 2018-04-29 22:44:03 UTC
Set to FIXED as I can see the menu item.

Version: 6.1.0.0.alpha1+
Build ID: 4dbce627d3643babaf90a93c70b365ff08abfca6
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: de-DE (de_DE.UTF-8); Calc: group
Comment 24 Dieter Praas 2018-07-11 07:06:42 UTC
*** Bug 118642 has been marked as a duplicate of this bug. ***