Download it now!
Bug 115368 - save dialog - character repeats continuously as soon as key pressed (with kde4)
Summary: save dialog - character repeats continuously as soon as key pressed (with kde4)
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2018-02-01 11:13 UTC by Owen Savill
Modified: 2019-02-28 08:42 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Savill 2018-02-01 11:13:05 UTC
Description:
As soon as any key is pressed in the file name box of the Save or Save As dialogs it just repeats over and over and won't stop.

Steps to Reproduce:
1.Open any document
2.Click Save As or Save for a new document
3.Pres a key in the Name field

Actual Results:  
The key repeats over and over preventing the name from being entered at all

Expected Results:
A single character should be produced.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
What happened to severity levels of high and critical. This is a show stopper as it prevents any filenames being entered at all.

Version: 6.0.0.3
Build ID: 64a0f66915f38c6217de274f0aa8e15618924765
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: en-GB (en_GB.UTF-8); Calc: group

OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: Quadro 2000M/PCIe/SSE2
OpenGL core profile version string: 4.5.0 NVIDIA 390.25
OpenGL core profile shading language version string: 4.50 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6.0 NVIDIA 390.25
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 390.25
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:



User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Xisco Faulí 2018-02-01 11:22:26 UTC
Does it happen if OpenGL is disabled ? https://wiki.documentfoundation.org/OpenGL
Comment 2 Owen Savill 2018-02-01 14:13:53 UTC
OpenGL is currently disabled. Enabling it breaks the rendering completely. The entire application flickers in and out. Made switching it off again very difficult!
Comment 3 Buovjaga 2018-02-24 15:10:20 UTC
Does it happen in Safe mode? Help - Restart in safe mode and then Continue in safe mode.
Comment 4 Owen Savill 2018-02-26 10:00:31 UTC
Yes, it does.
Comment 5 Buovjaga 2018-02-26 11:30:30 UTC
What if you launch from the command line with

SAL_USE_VCLPLUGIN=gtk libreoffice
Comment 6 Owen Savill 2018-02-26 13:38:58 UTC
That fixes it. Different save dialog appears and it doesn't suffer the key stroke repeat issue.
Comment 7 Owen Savill 2018-02-26 13:51:34 UTC
(Problem still in 6.0.1.1)
Comment 8 Buovjaga 2018-02-26 13:54:39 UTC
Ok, so it's limited to kde4. I use kde4 myself all the time, but have not seen this weirdness.

Arch Linux 64-bit
Version: 6.0.1.1
Build ID: 6.0.1-1
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Comment 9 Owen Savill 2018-02-26 14:32:42 UTC
I'm using KDE Plasma v5.12.2
Comment 10 Xisco Faulí 2018-11-26 18:39:55 UTC
(In reply to Owen Savill from comment #9)
> I'm using KDE Plasma v5.12.2

Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 11 Julien Nabet 2019-02-28 08:42:27 UTC
Let's put this one to RESOLVED/WONTFIX since kde4 isn't maintained anymore.

Recent LO versions use kde5.