Bug 115393 - 1bpp B&W PNG images are mis-exported to PDF (as black boxes)
Summary: 1bpp B&W PNG images are mis-exported to PDF (as black boxes)
Status: RESOLVED DUPLICATE of bug 115297
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.4.4.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-02 09:08 UTC by Michał Kępień
Modified: 2018-02-02 09:42 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example problematic image (451 bytes, image/png)
2018-02-02 09:17 UTC, Michał Kępień
Details
Writer document with the example problematic image inserted (9.61 KB, application/vnd.oasis.opendocument.text)
2018-02-02 09:18 UTC, Michał Kępień
Details
Writer document exported to PDF using LibreOffice 5.4.3.2 (good) (2.25 KB, application/pdf)
2018-02-02 09:19 UTC, Michał Kępień
Details
Writer document exported to PDF using LibreOffice 5.4.4.2 (bad) (2.07 KB, application/pdf)
2018-02-02 09:20 UTC, Michał Kępień
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michał Kępień 2018-02-02 09:08:31 UTC
Description:
When exported to PDF, 1bpp B&W PNG images are turned into boxes filled
with black.


Steps to Reproduce:
1. Insert a 1bpp B&W PNG image into a Writer document.
2. Export the document to PDF.
3. View the resulting PDF in any PDF viewer.


Actual Results:  
In the exported PDF, the inserted image is displayed as a black box.

Expected Results:
In the exported PDF, the inserted image should retain its original
contents.



Reproducible: Always


User Profile Reset: Yes



Additional Info:
I believe this issue was introduced by the fix for Bug #113875.
Exporting 1bpp B&W PNG images to PDF worked fine in version 5.4.3.2.

Converting the inserted PNG image to RGB mode using GIMP works around
the problem.



User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Michał Kępień 2018-02-02 09:17:24 UTC
Created attachment 139518 [details]
Example problematic image
Comment 2 Michał Kępień 2018-02-02 09:18:56 UTC
Created attachment 139519 [details]
Writer document with the example problematic image inserted
Comment 3 Michał Kępień 2018-02-02 09:19:53 UTC
Created attachment 139520 [details]
Writer document exported to PDF using LibreOffice 5.4.3.2 (good)
Comment 4 Michał Kępień 2018-02-02 09:20:17 UTC
Created attachment 139522 [details]
Writer document exported to PDF using LibreOffice 5.4.4.2 (bad)
Comment 5 Xisco Faulí 2018-02-02 09:42:17 UTC
Hi,
Thanks for reporting this issue.
It seems like a dupe of bug 115297

*** This bug has been marked as a duplicate of bug 115297 ***